View Issue Details

IDProjectCategoryView StatusLast Update
0001076XdebugUsage problems (Wrong Results)public2014-11-11 19:50
ReporterDarsVaedaAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformPHP Version 5.5.16-1~dotdeb.1OSDebianOS Versionwheezy
Product Version2.2.5 
Target VersionFixed in Version 
Summary0001076: "Added debug info handler to DOM objects" not working
Descriptionextended debug info using var_dump on DomDocument is not working
this has been described here:
https://bugs.php.net/bug.php?id=63910

and was reported fixed here:
http://bugs.xdebug.org/view.php?id=913
Steps To Reproducejust have xdebug enabled, see no detailed var_dump
disable xdebug via php.ini and get detailed var_dump
code same as in linked xdebug bug report:

<?php
$DOMDocumentNode = new DOMDocument();
$DOMDocumentNode->loadXML('<example a="b">Test</example>');
$DOMElementNode = $DOMDocumentNode->documentElement;
$DOMAttributeNode = $DOMElementNode->getAttributeNode('a');
$DOMTextNode = $DOMElementNode->firstChild;

var_dump($DOMDocumentNode, $DOMElementNode, $DOMAttributeNode, $DOMTextNode);
Additional InformationLinux packer-debian-7 3.2.0-4-amd64 #1 SMP Debian 3.2.60-1+deb7u3 x86_64
PHP Version 5.5.16-1~dotdeb.1
TagsNo tags attached.
Operating System
PHP Version5.5.5-5.5.9

Activities

derick

2014-11-11 19:50

administrator   ~0002898

Just like in 0000910 and 0000913, I can not reproduce this. I have tried versions
5.3.28-debug, 5.4.14-debug, 5.4.14-nodebug, 5.5.13-debug-zts and in each case
I am getting the expected output with lots of information for each of the 4
variables.

Issue History

Date Modified Username Field Change
2014-09-09 17:51 DarsVaeda New Issue
2014-11-11 19:50 derick Note Added: 0002898
2014-11-11 19:50 derick Status new => resolved
2014-11-11 19:50 derick Resolution open => unable to reproduce
2014-11-11 19:50 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)