View Issue Details

IDProjectCategoryView StatusLast Update
0001126XdebugUsage problems (Wrong Results)public2015-03-21 13:36
Reporteraik099Assigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.3.1 
Target VersionFixed in Version2.3.2 
Summary0001126: Getting glibc error during coverage collection
DescriptionAfter running PHPUnit with code coverage collection enabled I'm getting

*** glibc detected *** php: realloc(): invalid next size: 0x00000000015ef810 ***

error on specific test. This was working with xDebug 2.2.7.
Steps To Reproduce1. download Selenium server (jar file) from http://www.seleniumhq.org/download/ page
2. run it using "java -jar selenium-server-standalone-2.45.0.jar" command
3. clone https://github.com/qa-tools/qa-tools library
4. enable code coverage collection in phpunit.xml.dist
5. run "phpunit --filter testTextInputsLocatedByCss --tap" command
TagsNo tags attached.
Operating SystemLinux
PHP Version5.4.35-5.4.39

Activities

aik099

2015-03-07 08:48

reporter   ~0003039

When I'm running this on PHP 5.5 I also get a backtrace:

======= Backtrace: =========
/lib64/libc.so.6(+0x78206)[0x7f9a9c026206]
/lib64/libc.so.6(+0x7c98b)[0x7f9a9c02a98b]
/lib64/libc.so.6(realloc+0xf9)[0x7f9a9c02c129]
/usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/xdebug.so(+0x111f8)[0x7f9a9bb181f8]
/usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/xdebug.so(xdebug_path_info_add_path_for_level+0x28)[0x7f9a9bb18588]
/usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/xdebug.so(xdebug_code_coverage_start_of_function+0x35)[0x7f9a9bb1b505]
/usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/xdebug.so(xdebug_execute_ex+0x84c)[0x7f9a9bb15d4c]
/usr/local/php-5.5/bin/php[0x8a4c9c]
/usr/local/php-5.5/bin/php(execute_ex+0x59)[0x8671a9]
/usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/xdebug.so(xdebug_execute_ex+0x3a3)[0x7f9a9bb158a3]
/usr/local/php-5.5/bin/php(zend_call_function+0xa3e)[0x7e7e6e]
/usr/local/php-5.5/bin/php(zend_call_method+0x1c7)[0x80e3c7]
/usr/local/php-5.5/bin/php[0x6b4856]
/usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/xdebug.so(xdebug_execute_internal+0x31a)[0x7f9a9bb1534a]
/usr/local/php-5.5/bin/php(zend_call_function+0xc2f)[0x7e805f]
/usr/local/php-5.5/bin/php(zend_lookup_class_ex+0x241)[0x7e8541]
/usr/local/php-5.5/bin/php(zend_fetch_class_by_name+0x31)[0x7e8ed1]
/usr/local/php-5.5/bin/php[0x838473]
/usr/local/php-5.5/bin/php(execute_ex+0x59)[0x8671a9]
/usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/xdebug.so(xdebug_execute_ex+0x3a3)[0x7f9a9bb158a3]
/usr/local/php-5.5/bin/php[0x8a5328]
/usr/local/php-5.5/bin/php(execute_ex+0x59)[0x8671a9]
/usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/xdebug.so(xdebug_execute_ex+0x3a3)[0x7f9a9bb158a3]
/usr/local/php-5.5/bin/php[0x8a4c9c]
/usr/local/php-5.5/bin/php(execute_ex+0x59)[0x8671a9]
/usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/xdebug.so(xdebug_execute_ex+0x3a3)[0x7f9a9bb158a3]
/usr/local/php-5.5/bin/php(zend_call_function+0xa3e)[0x7e7e6e]
/usr/local/php-5.5/bin/php(zend_call_method+0x1c7)[0x80e3c7]
/usr/local/php-5.5/bin/php[0x6b4856]
/usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/xdebug.so(xdebug_execute_internal+0x31a)[0x7f9a9bb1534a]
/usr/local/php-5.5/bin/php(zend_call_function+0xc2f)[0x7e805f]
/usr/local/php-5.5/bin/php(zend_lookup_class_ex+0x241)[0x7e8541]
/usr/local/php-5.5/bin/php(zend_fetch_class_by_name+0x31)[0x7e8ed1]
/usr/local/php-5.5/bin/php[0x83413b]
/usr/local/php-5.5/bin/php(execute_ex+0x59)[0x8671a9]
/usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/xdebug.so(xdebug_execute_ex+0x3a3)[0x7f9a9bb158a3]
/usr/local/php-5.5/bin/php[0x8a5328]
/usr/local/php-5.5/bin/php(execute_ex+0x59)[0x8671a9]
/usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/xdebug.so(xdebug_execute_ex+0x3a3)[0x7f9a9bb158a3]
/usr/local/php-5.5/bin/php[0x8a4c9c]
/usr/local/php-5.5/bin/php(execute_ex+0x59)[0x8671a9]
/usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/xdebug.so(xdebug_execute_ex+0x3a3)[0x7f9a9bb158a3]
/usr/local/php-5.5/bin/php(zend_call_function+0xa3e)[0x7e7e6e]
/usr/local/php-5.5/bin/php(zend_call_method+0x1c7)[0x80e3c7]
/usr/local/php-5.5/bin/php[0x6b4856]
/usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/xdebug.so(xdebug_execute_internal+0x31a)[0x7f9a9bb1534a]
/usr/local/php-5.5/bin/php(zend_call_function+0xc2f)[0x7e805f]
/usr/local/php-5.5/bin/php(zend_lookup_class_ex+0x241)[0x7e8541]
/usr/local/php-5.5/bin/php(zend_fetch_class_by_name+0x31)[0x7e8ed1]
/usr/local/php-5.5/bin/php[0x83413b]
/usr/local/php-5.5/bin/php(execute_ex+0x59)[0x8671a9]
/usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/xdebug.so(xdebug_execute_ex+0x3a3)[0x7f9a9bb158a3]
/usr/local/php-5.5/bin/php[0x8a4c9c]
/usr/local/php-5.5/bin/php(execute_ex+0x59)[0x8671a9]
/usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/xdebug.so(xdebug_execute_ex+0x3a3)[0x7f9a9bb158a3]
/usr/local/php-5.5/bin/php[0x8a4c9c]
/usr/local/php-5.5/bin/php(execute_ex+0x59)[0x8671a9]
/usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/xdebug.so(xdebug_execute_ex+0x3a3)[0x7f9a9bb158a3]
/usr/local/php-5.5/bin/php[0x8a4c9c]
/usr/local/php-5.5/bin/php(execute_ex+0x59)[0x8671a9]
/usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/xdebug.so(xdebug_execute_ex+0x3a3)[0x7f9a9bb158a3]
/usr/local/php-5.5/bin/php[0x8a4c9c]
/usr/local/php-5.5/bin/php(execute_ex+0x59)[0x8671a9]
======= Memory map: ========
00400000-00f9d000 r-xp 00000000 08:01 450180 /usr/local/php-5.5/bin/php
0119d000-01265000 rw-p 00b9d000 08:01 450180 /usr/local/php-5.5/bin/php
01265000-02677000 rw-p 00000000 00:00 0 [heap]
7f9a94000000-7f9a94021000 rw-p 00000000 00:00 0
7f9a94021000-7f9a98000000 ---p 00000000 00:00 0
7f9a9b060000-7f9a9b075000 r-xp 00000000 08:01 452290 /usr/lib64/libgcc_s.so.1
7f9a9b075000-7f9a9b274000 ---p 00015000 08:01 452290 /usr/lib64/libgcc_s.so.1
7f9a9b274000-7f9a9b275000 rw-p 00014000 08:01 452290 /usr/lib64/libgcc_s.so.1
7f9a9b275000-7f9a9b281000 r-xp 00000000 08:01 682806 /lib64/libnss_files-2.13.so
7f9a9b281000-7f9a9b480000 ---p 0000c000 08:01 682806 /lib64/libnss_files-2.13.so
7f9a9b480000-7f9a9b481000 r--p 0000b000 08:01 682806 /lib64/libnss_files-2.13.so
7f9a9b481000-7f9a9b482000 rw-p 0000c000 08:01 682806 /lib64/libnss_files-2.13.so
7f9a9b4a5000-7f9a9b527000 rw-p 00000000 00:00 0
7f9a9b528000-7f9a9b6ef000 rw-p 00000000 00:00 0
7f9a9b6f0000-7f9a9b8f8000 rw-p 00000000 00:00 0
7f9a9b8f8000-7f9a9b906000 r-xp 00000000 08:01 451040 /usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/memcache.so
7f9a9b906000-7f9a9bb06000 ---p 0000e000 08:01 451040 /usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/memcache.so
7f9a9bb06000-7f9a9bb07000 rw-p 0000e000 08:01 451040 /usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/memcache.so
7f9a9bb07000-7f9a9bb3d000 r-xp 00000000 08:01 450294 /usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/xdebug.so
7f9a9bb3d000-7f9a9bd3d000 ---p 00036000 08:01 450294 /usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/xdebug.so
7f9a9bd3d000-7f9a9bd41000 rw-p 00036000 08:01 450294 /usr/local/php-5.5/lib/php/extensions/no-debug-non-zts-20121212/xdebug.so
7f9a9bd41000-7f9a9bd90000 rw-p 00000000 00:00 0
7f9a9bd90000-7f9a9bda8000 r-xp 00000000 08:01 682808 /lib64/libpthread-2.13.so
7f9a9bda8000-7f9a9bfa8000 ---p 00018000 08:01 682808 /lib64/libpthread-2.13.so
7f9a9bfa8000-7f9a9bfa9000 r--p 00018000 08:01 682808 /lib64/libpthread-2.13.so
7f9a9bfa9000-7f9a9bfaa000 rw-p 00019000 08:01 682808 /lib64/libpthread-2.13.so
7f9a9bfaa000-7f9a9bfae000 rw-p 00000000 00:00 0
7f9a9bfae000-7f9a9c14c000 r-xp 00000000 08:01 698155 /lib64/libc-2.13.so
7f9a9c14c000-7f9a9c34c000 ---p 0019e000 08:01 698155 /lib64/libc-2.13.so
7f9a9c34c000-7f9a9c350000 r--p 0019e000 08:01 698155 /lib64/libc-2.13.so
7f9a9c350000-7f9a9c351000 rw-p 001a2000 08:01 698155 /lib64/libc-2.13.so
7f9a9c351000-7f9a9c357000 rw-p 00000000 00:00 0
7f9a9c357000-7f9a9c49f000 r-xp 00000000 08:01 495383 /usr/lib64/libxml2.so.2.7.8
7f9a9c49f000-7f9a9c69f000 ---p 00148000 08:01 495383 /usr/lib64/libxml2.so.2.7.8
7f9a9c69f000-7f9a9c6a8000 rw-p 00148000 08:01 495383 /usr/lib64/libxml2.so.2.7.8
7f9a9c6a8000-7f9a9c6aa000 rw-p 00000000 00:00 0
7f9a9c6aa000-7f9a9c6e4000 r-xp 00000000 08:01 431409 /usr/lib64/libxslt.so.1.1.26
7f9a9c6e4000-7f9a9c8e4000 ---p 0003a000 08:01 431409 /usr/lib64/libxslt.so.1.1.26
7f9a9c8e4000-7f9a9c8e6000 rw-p 0003a000 08:01 431409 /usr/lib64/libxslt.so.1.1.26
7f9a9c8e6000-7f9a9c960000 r-xp 00000000 08:01 436786 /usr/lib64/libnetsnmp.so.25.0.1
7f9a9c960000-7f9a9cb60000 ---p 0007a000 08:01 436786 /usr/lib64/libnetsnmp.so.25.0.1
7f9a9cb60000-7f9a9cb64000 rw-p 0007a000 08:01 436786 /usr/lib64/libnetsnmp.so.25.0.1
7f9a9cb64000-7f9a9cb98000 rw-p 00000000 00:00 0
7f9a9cb98000-7f9a9cc20000 r-xp 00000000 08:01 425973 /usr/lib64/libfreetype.so.6.10.0
7f9a9cc20000-7f9a9ce20000 ---p 00088000 08:01 425973 /usr/lib64/libfreetype.so.6.10.0
7f9a9ce20000-7f9a9ce26000 rw-p 00088000 08:01 425973 /usr/lib64/libfreetype.so.6.10.0
7f9a9ce26000-7f9a9ce3d000 r-xp 00000000 08:01 682809 /lib64/libresolv-2.13.so
7f9a9ce3d000-7f9a9d03d000 ---p 00017000 08:01 682809 /lib64/libresolv-2.13.so
7f9a9d03d000-7f9a9d03e000 r--p 00017000 08:01 682809 /lib64/libresolv-2.13.so
7f9a9d03e000-7f9a9d03f000 rw-p 00018000 08:01 682809 /lib64/libresolv-2.13.so
7f9a9d03f000-7f9a9d041000 rw-p 00000000 00:00 0
7f9a9d041000-7f9a9d05a000 r-xp 00000000 08:01 435309 /usr/lib64/libsasl2.so.2.0.23
7f9a9d05a000-7f9a9d259000 ---p 00019000 08:01 435309 /usr/lib64/libsasl2.so.2.0.23
7f9a9d259000-7f9a9d25a000 rw-p 00018000 08:01 435309 /usr/lib64/libsasl2.so.2.0.23
7f9a9d25a000-7f9a9d267000 r-xp 00000000 08:01 392567 /usr/lib64/liblber-2.4.so.2.5.6
7f9a9d267000-7f9a9d467000 ---p 0000d000 08:01 392567 /usr/lib64/liblber-2.4.so.2.5.6Aborted

derick

2015-03-07 13:16

administrator   ~0003040

Can you try the xdebug_2_3 branch from github? This looks like something I've fixed already.

aik099

2015-03-07 17:09

reporter   ~0003041

Yes, it's indeed was fixed on xdebug_2_3 branch. Thanks.

derick

2015-03-07 17:29

administrator   ~0003042

Okay. I'll make a new release soon.

derick

2015-03-21 13:36

administrator   ~0003049

I'm closing this one as a duplicate, because I've already fixed it.

Issue History

Date Modified Username Field Change
2015-03-07 08:40 aik099 New Issue
2015-03-07 08:48 aik099 Note Added: 0003039
2015-03-07 13:16 derick Note Added: 0003040
2015-03-07 13:16 derick Assigned To => derick
2015-03-07 13:16 derick Status new => feedback
2015-03-07 17:09 aik099 Note Added: 0003041
2015-03-07 17:09 aik099 Status feedback => assigned
2015-03-07 17:29 derick Note Added: 0003042
2015-03-21 13:36 derick Note Added: 0003049
2015-03-21 13:36 derick Status assigned => resolved
2015-03-21 13:36 derick Fixed in Version => 2.3.2
2015-03-21 13:36 derick Resolution open => duplicate
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)