View Issue Details

IDProjectCategoryView StatusLast Update
0001187XdebugUsage problems (Wrong Results)public2015-11-20 17:51
ReporterMajkl578Assigned Toderick 
PriorityhighSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0001187: Segfaults related to autoloading & PHP 7
DescriptionHi,

I have a project based on Symfony (via composer) which uses PHP7-only code.
I'm using PHP 7.0.0 RC3. Everything works fine until I load XDebug, then it starts to segfault. It seems to be related to composer autoloading.
BT is attached. If you need more info, please tell me how to proceed.

XDebug compiled from 5d0194a0d.
Additional Information#0 0x00007fffebfc0324 in xdebug_execute_ex (execute_data=0x7fffec214540) at /build/php/ext/xdebug/xdebug.c:1641
#1 0x0000000000a7acb4 in zend_call_function (fci=0x7fffffffa1a0, fci_cache=0x7fffffffa140) at /build/php/php-src/Zend/zend_execute_API.c:853
0000002 0x0000000000ab7aad in zend_call_method (object=0x7fffec2e19b8, obj_ce=0x7fffeba563b0, fn_proxy=0x7fffec2e19b0, function_name=0x7fffec313a98 "symfony\\component\\debug\\debugclassloader::loadclass\005",
    function_name_len=55, retval_ptr=0x0, param_count=1, arg1=0x7fffec214530, arg2=0x0) at /build/php/php-src/Zend/zend_interfaces.c:104
0000003 0x000000000087bed3 in zif_spl_autoload_call (execute_data=0x7fffec2144d0, return_value=0x7fffffffa5b0) at /build/php/php-src/ext/spl/php_spl.c:425
0000004 0x0000000000aea2a7 in execute_internal (execute_data=0x7fffec2144d0, return_value=0x7fffffffa5b0) at /build/php/php-src/Zend/zend_execute.c:2036
0000005 0x00007fffebfc115c in xdebug_execute_internal (current_execute_data=0x7fffec2144d0, return_value=0x7fffffffa5b0) at /build/php/ext/xdebug/xdebug.c:1994
0000006 0x0000000000a7add9 in zend_call_function (fci=0x7fffffffa560, fci_cache=0x7fffffffa530) at /build/php/php-src/Zend/zend_execute_API.c:874
0000007 0x0000000000a7b4b6 in zend_lookup_class_ex (name=0x7fffeba7e930, key=0x7fffec318670, use_autoload=1) at /build/php/php-src/Zend/zend_execute_API.c:1035
0000008 0x0000000000a7bf4e in zend_fetch_class_by_name (class_name=0x7fffeba7e930, key=0x7fffec318670, fetch_type=512) at /build/php/php-src/Zend/zend_execute_API.c:1382
0000009 0x0000000000af2f12 in ZEND_NEW_SPEC_CONST_HANDLER () at /build/php/php-src/Zend/zend_vm_execute.h:3343
0000010 0x0000000000aeefd3 in ZEND_USER_OPCODE_SPEC_HANDLER () at /build/php/php-src/Zend/zend_vm_execute.h:1583
0000011 0x0000000000aeb83d in execute_ex (ex=0x7fffec214270) at /build/php/php-src/Zend/zend_vm_execute.h:406
0000012 0x00007fffebfc0bfa in xdebug_execute_ex (execute_data=0x7fffec214270) at /build/php/ext/xdebug/xdebug.c:1847
0000013 0x0000000000aec7e0 in ZEND_DO_FCALL_SPEC_HANDLER () at /build/php/php-src/Zend/zend_vm_execute.h:791
0000014 0x0000000000aeefd3 in ZEND_USER_OPCODE_SPEC_HANDLER () at /build/php/php-src/Zend/zend_vm_execute.h:1583
0000015 0x0000000000aeb83d in execute_ex (ex=0x7fffec214030) at /build/php/php-src/Zend/zend_vm_execute.h:406
0000016 0x00007fffebfc0bfa in xdebug_execute_ex (execute_data=0x7fffec214030) at /build/php/ext/xdebug/xdebug.c:1847
0000017 0x0000000000aeb94e in zend_execute (op_array=0x7fffec283000, return_value=0x0) at /build/php/php-src/Zend/zend_vm_execute.h:450
0000018 0x0000000000a92029 in zend_execute_scripts (type=8, retval=0x0, file_count=3) at /build/php/php-src/Zend/zend.c:1400
0000019 0x0000000000a03334 in php_execute_script (primary_file=0x7fffffffdf60) at /build/php/php-src/main/main.c:2471
---Type <return> to continue, or q <return> to quit---
0000020 0x0000000000b4f38c in do_cli (argc=2, argv=0x14cfe50) at /build/php/php-src/sapi/cli/php_cli.c:971
0000021 0x0000000000b50356 in main (argc=2, argv=0x14cfe50) at /build/php/php-src/sapi/cli/php_cli.c:1342
Tagscrash, PHP7
Operating System
PHP Version7.0RCx

Activities

hacfi

2015-10-15 07:39

reporter   ~0003180

The affected line of code seems to be https://github.com/symfony/Debug/blob/master/DebugClassLoader.php#L152

derick

2015-10-22 23:00

administrator   ~0003185

Can you provide me with a *short* reproducible script, or at least, very detailed instructions as to how to reproduce this bug? (Assume I know nothing about composer and symfony).

With the information in this report I can do nothing. Please also include your Xdebug and exact PHP version.

hacfi

2015-10-23 11:59

reporter   ~0003192

Don‘t have time to test this but this will get you started:

curl -sS https://getcomposer.org/installer | php
php composer.phar create-project symfony/framework-standard-edition test
cd test
php app/console doctrine:database:create

should already crash

hacfi

2015-10-23 12:04

reporter   ~0003193

Don‘t have time to test this but this will get you started:

curl -sS https://getcomposer.org/installer | php
php composer.phar create-project symfony/framework-standard-edition test
cd test
php app/console doctrine:database:create

should already crash

derick

2015-11-09 01:53

administrator   ~0003212

I can not reproduce any crash with the latest Xdebug from GIT and your reproduce case. It works "fine":

derick@whisky:/tmp/test2 $ php app/console doctrine:database:createCreated database `symfony` for connection named default
derick@whisky:/tmp/test2 $

derick

2015-11-20 17:51

administrator   ~0003243

Can't reproduce this, and no feedback provided. Assume it was fixed with earlier fixes.

Issue History

Date Modified Username Field Change
2015-09-22 11:25 Majkl578 New Issue
2015-09-22 11:25 Majkl578 Tag Attached: PHP7
2015-09-22 11:25 Majkl578 Tag Attached: crash
2015-10-15 07:39 hacfi Note Added: 0003180
2015-10-22 23:00 derick Note Added: 0003185
2015-10-22 23:00 derick Assigned To => derick
2015-10-22 23:00 derick Status new => feedback
2015-10-23 11:59 hacfi Note Added: 0003192
2015-10-23 12:04 hacfi Note Added: 0003193
2015-11-09 01:53 derick Note Added: 0003212
2015-11-20 17:51 derick Note Added: 0003243
2015-11-20 17:51 derick Status feedback => resolved
2015-11-20 17:51 derick Resolution open => unable to reproduce
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)