View Issue Details

IDProjectCategoryView StatusLast Update
0001409XdebugRemote Debuggingpublic2019-08-23 23:41
ReporterfordiyAssigned Toderick 
PriorityimmediateSeveritymajorReproducibilityhave not tried
Status resolvedResolutionwon't fix 
Product Version2.5.1 
Target VersionFixed in Version 
Summary0001409: xdebug 2.5.1 not work on PHP version: 7.0.15-0 ubuntu0.16.04.4
DescriptionI cannot enable the xdebug.remote_enable why? And I cannot debug as normal. Anyone know what's problem with xdebug?

http://stackoverflow.com/questions/43042303/xdebug-2-5-1-not-work-on-php-version-7-0-15-0-ubuntu0-16-04-4
Steps To ReproduceBelow is my /etc/php/7.0/cli/php.ini
[XDebug]
zend_extension = /usr/lib/php/20151012/xdebug.so
xdebug.remote_enable = on
xdebug.remote_connect_back= on
xdebug.remote_autostart = on
xdebug.remote_port=9000
xdebug.idekey=PHPSTORM
Additional Informationhttp://stackoverflow.com/questions/43042303/xdebug-2-5-1-not-work-on-php-version-7-0-15-0-ubuntu0-16-04-4
TagsNo tags attached.
Operating SystemPHP 7.0.15-0 ubuntu0.16.04.4
PHP Version7.0.15-7.0.19

Relationships

has duplicate 0001408 resolvedderick xdebug 2.5.1 not work on PHP version: 7.0.15-0 ubuntu0.16.04.4 

Activities

fordiy

2017-03-27 09:22

reporter  

20170327170252.png (19,633 bytes)
20170327170252.png (19,633 bytes)

fordiy

2017-03-27 09:23

reporter  

20170327170427.png (29,474 bytes)
20170327170427.png (29,474 bytes)

derick

2017-03-27 09:59

administrator   ~0004243

If xdebug.remote_enable = on does not work, you're changing the wrong ini file. The top of phpinfo() will tell you which ini file(s) are loaded, and you need to make sure one of these sets xdebug.remote_enable = on and *none* of them do the opposite.

fordiy

2017-03-27 10:02

reporter   ~0004244

It's correct INI file. I changed other options, all OK. Only xdebug.remote_enable NOT work. Please see below path:
Xdebug installed: 2.5.1
Server API: Command Line Interface
Windows: no
Zend Server: no
PHP Version: 7.0.15-0
Zend API nr: 320151012
PHP API nr: 20151012
Debug Build: no
Thread Safe Build: no
Configuration File Path: /etc/php/7.0/cli
Configuration File: /etc/php/7.0/cli/php.ini
Extensions directory: /usr/lib/php/20151012

fordiy

2017-03-27 10:37

reporter   ~0004245

Help!

Issue History

Date Modified Username Field Change
2017-03-27 09:22 fordiy New Issue
2017-03-27 09:22 fordiy File Added: 20170327170252.png
2017-03-27 09:23 fordiy File Added: 20170327170427.png
2017-03-27 09:59 derick Note Added: 0004243
2017-03-27 09:59 derick Assigned To => derick
2017-03-27 09:59 derick Status new => feedback
2017-03-27 10:02 fordiy Note Added: 0004244
2017-03-27 10:02 fordiy Status feedback => assigned
2017-03-27 10:37 fordiy Note Added: 0004245
2017-04-01 10:40 derick Relationship added has duplicate 0001408
2019-08-23 23:41 derick Status assigned => resolved
2019-08-23 23:41 derick Resolution open => won't fix