View Issue Details

IDProjectCategoryView StatusLast Update
0001478XdebugUsage problems (Wrong Results)public2018-01-29 21:56
Reporteraik099Assigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.4.0 
Target VersionFixed in Version 
Summary0001478: Object properties with dash can't be inspected
DescriptionI've used `json_decode` (as object, not an array) on contents of `composer.json` file that has `require-dev` key in it. In PhpStorm, when attempting to see what's inside `require-dev` the content wasn't shown, because xdebug tried to get `require` object property value instead of `require-dev`.
TagsNo tags attached.
Operating SystemSlackware
PHP Version5.4.45-5.4.50

Relationships

duplicate of 0001520 closedderick Xdebug does not handle variable names with "-" in their name 

Activities

derick

2017-10-08 09:58

administrator   ~0004438

Can you please follow the instructions at https://xdebug.org/support.php#remote ?

aik099

2017-10-08 10:20

reporter  

xdebug_remote.log (20,882 bytes)

aik099

2017-10-08 10:21

reporter   ~0004439

Last edited: 2017-10-08 10:21

View 2 revisions

Script:

<?php

$json = <<<JSON
{
    "autoload": {
        "psr-4": {
            "aik099\\\\": "./src/"
        }
    },
    "require-dev": {
        "aik099/coding-standard": "dev-master"
    }
}
JSON;

$parsed = json_decode($json);
// Try viewing details of "$parsed->{require-dev} key in the PhpStorm's "Variables" panel.
echo '';

?>

CLI output (when attempting to view class property with dash):

PHP Notice: Undefined property: stdClass::$psr in .../remote_debug_bug.php on line 18
PHP Stack trace:
PHP 1. {main}() .../remote_debug_bug.php:0
PHP Notice: Undefined property: stdClass::$require in .../remote_debug_bug.php on line 18
PHP Stack trace:
PHP 1. {main}() .../remote_debug_bug.php:0

Remote debug log attached above.

derick

2018-01-29 21:56

administrator   ~0004588

Duplicate of 0001520, which has a better description.

Issue History

Date Modified Username Field Change
2017-10-08 09:47 aik099 New Issue
2017-10-08 09:58 derick Note Added: 0004438
2017-10-08 09:58 derick Assigned To => derick
2017-10-08 09:58 derick Status new => feedback
2017-10-08 10:20 aik099 File Added: xdebug_remote.log
2017-10-08 10:21 aik099 Note Added: 0004439
2017-10-08 10:21 aik099 Status feedback => assigned
2017-10-08 10:21 aik099 Note Edited: 0004439 View Revisions
2018-01-29 21:56 derick Note Added: 0004588
2018-01-29 21:56 derick Relationship added duplicate of 0001520
2018-01-29 21:56 derick Status assigned => resolved
2018-01-29 21:56 derick Resolution open => duplicate