View Issue Details

IDProjectCategoryView StatusLast Update
0001538XdebugInstallationpublic2018-03-30 13:09
ReporterjswilsonAssigned Toderick 
PriorityhighSeverityblockReproducibilityalways
Status resolvedResolutionno change required 
PlatformApple MacOSmacOS High SierraOS VersionOS X 10.13.3
Product Version2.6.0 
Target VersionFixed in Version 
Summary0001538: xdebug can't be installed on OS X 10.13
DescriptionI tried to install xdebug 2.6.0 a number of ways and each time it fails to install. It reports:
Warning: You are using OS X 10.13.
We do not provide support for this pre-release version.
Steps To Reproducebrew install homebrew/php/php72-xdebug
Additional InformationTrying to install using:https://xdebug.org/wizard.php also fails as phpize will not work because
brew install autoconf does not work.
TagsNo tags attached.
Operating SystemmacOS High Sierra OS X 10.13.3
PHP Version7.2.0-7.2.4

Activities

jswilson

2018-03-21 15:00

reporter   ~0004621

In order to install xdebug, xcode command line tools needs to be installed. That can be done with this command:
xcode-select --install
After this is completed xdebug can be installed.

derick

2018-03-30 13:09

administrator   ~0004625

Closing this out then, as this is not strictly related to Xdebug.

Issue History

Date Modified Username Field Change
2018-03-21 01:20 jswilson New Issue
2018-03-21 15:00 jswilson Note Added: 0004621
2018-03-30 13:09 derick Note Added: 0004625
2018-03-30 13:09 derick Status new => resolved
2018-03-30 13:09 derick Resolution open => no change required
2018-03-30 13:09 derick Assigned To => derick