View Issue Details

IDProjectCategoryView StatusLast Update
0001703XdebugInstallationpublic2019-09-19 17:48
ReporterEmiliaDrupalAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformMAC OSOSHigh SierraOS Version10.13.6
Product Version2.7.2 
Target VersionFixed in Version 
Summary0001703: Symbol not found: _compiler_globals
DescriptionHello!
I had the xdebug up and running on my MAC OS High Sierra 10.13.6 until i installed PEAR and ran some brew update.
Now the xdebug does not work at all with my PHP Storm. If i do a php -i or run any drush command i get:
Failed loading /Applications/DevDesktop/php7_2_x64/ext/xdebug.so: dlopen(/Applications/DevDesktop/php7_2_x64/ext/xdebug.so, 9): Symbol not found: _compiler_globals
  Referenced from: /Applications/DevDesktop/php7_2_x64/ext/xdebug.so
  Expected in: flat namespace
 in /Applications/DevDesktop/php7_2_x64/ext/xdebug.so
My PHP version is 7.2.18.
I tried reinstalling xdebug using the steps provided by https://xdebug.org/wizard.php
After reinstalling it if i analyse my phpinfo() output on the wizard again it keeps showing me Xdebug installed: no
Additional InformationXdebug installed: no
Server API: Command Line Interface
Windows: no
Zend Server: no
PHP Version: 7.2.18
Zend API nr: 320170718
PHP API nr: 20170718
Debug Build: no
Thread Safe Build: yes
OPcache Loaded: yes
Configuration File Path: /Users/acquia/csbworkdir/mak/php7_2-osx/install/lib
Configuration File: /Applications/DevDesktop/php7_2_x64/bin/php.ini
Extensions directory: /Applications/DevDesktop/php7_2_x64/ext

In /Applications/DevDesktop/php7_2_x64/bin/php.ini i have this line added: zend_extension="/Applications/DevDesktop/php7_2_x64/ext/xdebug.so"
Tagserror
Operating SystemMAC OS High Sierra
PHP Version7.2.15-7.2.19

Activities

derick

2019-09-19 17:48

administrator   ~0005151

"Symbol not found: _compiler_globals" indicates that your PHP is build with a different thread-safey-ness as Xdebug. I don't understand why "brew update" should mess that up (you'll have to ask them!).

The output from the wizard indicates that it thinks that your PHP is compiled *with* thread safe mode enabled ("Thread Safe Build: yes"), but I probably think that you pasted the wrong PHP's output. It matters that use the same "php" command for which you want to install Xdebug for also creates the phpinfo() output (or "php -i") that you feed into the wizard. It is also possible that the wizard gets it wrong, as there is a possibility that you have multiple sets of PHP and its headers installed. The difference between the paths in "Configuration File Path: /Users/acquia/csbworkdir/mak/php7_2-osx/install/lib" and " Extensions directory: /Applications/DevDesktop/php7_2_x64/ext" hints at that.

As this is not a bug, I am closing this issue, and kindly refer you to StackOverflow for support: https://stackoverflow.com/questions/tagged/xdebug

Issue History

Date Modified Username Field Change
2019-09-19 10:36 EmiliaDrupal New Issue
2019-09-19 10:36 EmiliaDrupal Tag Attached: error
2019-09-19 17:48 derick Assigned To => derick
2019-09-19 17:48 derick Status new => resolved
2019-09-19 17:48 derick Resolution open => no change required
2019-09-19 17:48 derick Note Added: 0005151