View Issue Details

IDProjectCategoryView StatusLast Update
0001729XdebugInstallationpublic2020-01-12 16:47
ReportershivamAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionnot fixable 
PlatformLinux amd64OSUbuntuOS Version 18.04
Product Version2.9.0 
Target VersionFixed in Version 
Summary0001729: Upgrading to newer version of Xdebug using PECL when older version is enabled results in segmentation fault.
DescriptionWhen upgrading to 2.9.0 using PECL when 2.8.0 is loaded in memory results in segmentation fault.
This happens at the end of installation perhaps because PHP tries to load the new binary.

Disabling the extension before upgrading and enabling afterwards is a smooth process.
Steps To ReproduceOn ubuntu create a fresh installation of PHP7.4 using the package from https://launchpad.net/~ondrej/+archive/ubuntu/php
Install Xdebug and PECL and try upgrading using PECL

sudo add-apt-repository ppa:ondrej/php
sudo apt-get update
sudo apt-get install php7.4 php7.4-xdebug
wget https://pear.php.net/go-pear.phar && go-pear.phar
sudo pear config-set php_ini /etc/php/7.4/cli/php.ini
sudo pear config-set auto_discover 1
sudo pear channel-update pear.php.net
pecl install -f xdebug-2.9.0
>> Segmentation fault (core dumped)
Tagspear, pecl
Operating SystemUbuntu
PHP Version7.4.0-7.4.4

Activities

derick

2020-01-12 16:47

administrator   ~0005213

Hi,

I can indeed confirm this, although this only recently started to become a problem for me. It has been reported in the past (0000793), and also in other packages, such as https://github.com/pdezwart/php-amqp/issues/95 and https://github.com/grpc/grpc/issues/15210). This is not a bug in Xdebug, as it's the PECL installer that causes this by overwriting a binary that is already in use (I believe). As a workaround, you can temporarily disable xdebug.so in php.ini (by using the `;` at the start of the `zend_extension=xdebug.so` line) when running "pecl install", and then reenabling Xdebug.

cheers,
Derick

Issue History

Date Modified Username Field Change
2019-12-10 00:49 shivam New Issue
2019-12-10 00:49 shivam Tag Attached: pear
2019-12-10 00:49 shivam Tag Attached: pecl
2020-01-12 16:47 derick Assigned To => derick
2020-01-12 16:47 derick Status new => resolved
2020-01-12 16:47 derick Resolution open => not fixable
2020-01-12 16:47 derick Note Added: 0005213