View Issue Details

IDProjectCategoryView StatusLast Update
0001874XdebugUncategorizedpublic2020-11-03 17:36
Reporterremi Assigned Toderick  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version3.0.0beta1 
Target Version3.0.0RC1Fixed in Version3.0.0RC1 
Summary0001874: Incompatibility with protobuf extension
DescriptionRunning phpunit (on phpunit/php-codecoverage component)

(gdb) bt

#0 xdebug_add_stack_frame (zdata=<optimized out>, zdata@entry=0x0, op_array=op_array@entry=0x7ffff7279000, type=type@entry=2)
    at /usr/src/debug/php73-php-pecl-xdebug3-3.0.0~beta1-1.fc31.remi.x86_64/NTS/src/base/base.c:587
#1 0x00007ffff7529493 in xdebug_execute_ex (execute_data=0x7ffff721e030) at /usr/src/debug/php73-php-pecl-xdebug3-3.0.0~beta1-1.fc31.remi.x86_64/NTS/src/base/base.c:725
0000002 0x00005555558818e7 in zend_execute ()
0000003 0x00005555557ea267 in zend_eval_stringl ()
0000004 0x00007fffebe0e3ee in zm_activate_protobuf () from /opt/remi/php73/root/usr/lib64/php/modules/protobuf.so
0000005 0x00005555557fcf60 in zend_activate_modules ()
0000006 0x000055555579798c in php_request_startup ()
0000007 0x0000555555883964 in do_cli ()
0000008 0x0000555555663098 in main ()
Additional InformationDon't know is related to 0001864
TagsNo tags attached.
Operating System
PHP Version7.4.0-7.4.4

Relationships

duplicate of 0001864 closedderick Incompatibility with PCS and protobuf extensions 

Activities

remi

2020-10-30 13:44

reporter   ~0005486

Encountered with PHP 7.3.24 (haven't test other versions)

remi

2020-10-30 13:50

reporter   ~0005487

Same segfault with 7.3.24 and 7.4.12

derick

2020-11-03 16:43

administrator   ~0005492

I'm pretty sure that this is related to 0001864.

derick

2020-11-03 17:36

administrator   ~0005496

I can reproduce this with the following line:

valgrind php -n -dzend_extension=xdebug -dextension=protobuf -r 'echo "hi";' 2>&1 | less


And it shows the exact same cause as in 0001864, so I'm closing this out as a duplicate.

Issue History

Date Modified Username Field Change
2020-10-30 13:43 remi New Issue
2020-10-30 13:44 remi Note Added: 0005486
2020-10-30 13:50 remi Note Added: 0005487
2020-11-03 16:43 derick Note Added: 0005492
2020-11-03 17:26 derick Target Version => 3.0.0RC1
2020-11-03 17:26 derick Summary Incompatibility with protoduf extension => Incompatibility with protobuf extension
2020-11-03 17:36 derick Assigned To => derick
2020-11-03 17:36 derick Status new => resolved
2020-11-03 17:36 derick Resolution open => duplicate
2020-11-03 17:36 derick Note Added: 0005496
2020-11-03 17:36 derick Relationship added duplicate of 0001864
2020-11-03 17:36 derick Fixed in Version => 3.0.0RC1