MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000193XdebugInstallationpublic2006-07-27 04:382006-08-14 09:15
Reporterjudas_iscariote 
Assigned To 
PrioritynormalSeveritytweakReproducibilityalways
StatusclosedResolutionreopened 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000193: Won't compile with PHP 5.2RC2-dev
DescriptionExtension does not compile against PHP 5.2RC2-dev
Additional Information/home/cristian/xdebug_clean/xdebug/xdebug.c:181: warning: initialization makes integer from pointer without a cast
/home/cristian/xdebug_clean/xdebug/xdebug.c: In function 'add_stack_frame':
/home/cristian/xdebug_clean/xdebug/xdebug.c:971: error: 'allocated_memory' undeclared (first use in this function)
/home/cristian/xdebug_clean/xdebug/xdebug.c:971: error: (Each undeclared identifier is reported only once
/home/cristian/xdebug_clean/xdebug/xdebug.c:971: error: for each function it appears in.)
/home/cristian/xdebug_clean/xdebug/xdebug.c: In function 'return_trace_stack_frame_computerized':
/home/cristian/xdebug_clean/xdebug/xdebug.c:1782: error: 'allocated_memory' undeclared (first use in this function)
/home/cristian/xdebug_clean/xdebug/xdebug.c: In function 'xdebug_throw_exception_hook':
/home/cristian/xdebug_clean/xdebug/xdebug.c:1854: warning: passing argument 1 of 'xdebug_hash_extended_find' from incompatible pointer type
/home/cristian/xdebug_clean/xdebug/xdebug.c: In function 'xdebug_error_cb':
/home/cristian/xdebug_clean/xdebug/xdebug.c:1952: error: 'memory_limit' undeclared (first use in this function)
/home/cristian/xdebug_clean/xdebug/xdebug.c:1952: error: invalid lvalue in assignment
/home/cristian/xdebug_clean/xdebug/xdebug.c: In function 'xdebug_stop_trace':
/home/cristian/xdebug_clean/xdebug/xdebug.c:2424: error: 'allocated_memory' undeclared (first use in this function)
/home/cristian/xdebug_clean/xdebug/xdebug.c: In function 'zif_xdebug_memory_usage':
/home/cristian/xdebug_clean/xdebug/xdebug.c:2502: error: 'allocated_memory' undeclared (first use in this function)
/home/cristian/xdebug_clean/xdebug/xdebug.c: In function 'zif_xdebug_peak_memory_usage':
/home/cristian/xdebug_clean/xdebug/xdebug.c:2507: error: 'allocated_memory_peak' undeclared (first use in this function)
TagsNo tags attached.
Operating Systemlinux
PHP Version5.1-dev
Attached Files

- Relationships

-  Notes
(0000428)
derick (administrator)
2006-08-11 18:05

This is fixed in CVS now.
(0000430)
judas_iscariote (reporter)
2006-08-14 07:38

yup, but now we have another error.

/bin/sh /home/cristian/xdebug/libtool --mode=compile gcc -I. -I/home/cristian/xdebug -DPHP_ATOM_INC -I/home/cristian/xdebug/include -I/home/cristian/xdebug/main -I/home/cristian/xdebug -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -DHAVE_CONFIG_H -g -O0 -c /home/cristian/xdebug/xdebug.c -o xdebug.lo
 gcc -I. -I/home/cristian/xdebug -DPHP_ATOM_INC -I/home/cristian/xdebug/include -I/home/cristian/xdebug/main -I/home/cristian/xdebug -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -DHAVE_CONFIG_H -g -O0 -c /home/cristian/xdebug/xdebug.c -fPIC -DPIC -o .libs/xdebug.o
/home/cristian/xdebug/xdebug.c: In function 'xdebug_execute':
/home/cristian/xdebug/xdebug.c:1254: error: too few arguments to function 'php_setcookie'
/home/cristian/xdebug/xdebug.c:1268: error: too few arguments to function 'php_setcookie'
/home/cristian/xdebug/xdebug.c:1284: error: too few arguments to function 'php_setcookie'
/home/cristian/xdebug/xdebug.c: In function 'xdebug_throw_exception_hook':
/home/cristian/xdebug/xdebug.c:1858: warning: passing argument 1 of 'xdebug_hash_extended_find' from incompatible pointer type
(0000432)
derick (administrator)
2006-08-14 09:15

Fixed in CVS again. But please report compile errors to the xdebug-dev@lists.xdebug.org mailinglist are they are often just because of changes in PHP itself.

- Issue History
Date Modified Username Field Change
2006-07-27 04:38 judas_iscariote New Issue
2006-08-11 18:05 derick Status new => closed
2006-08-11 18:05 derick Note Added: 0000428
2006-08-14 07:38 judas_iscariote Status closed => feedback
2006-08-14 07:38 judas_iscariote Resolution open => reopened
2006-08-14 07:38 judas_iscariote Note Added: 0000430
2006-08-14 09:15 derick Status feedback => closed
2006-08-14 09:15 derick Note Added: 0000432


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker