View Issue Details

IDProjectCategoryView StatusLast Update
0002003XdebugInstallationpublic2021-08-06 17:44
Reporterjekpad Assigned Toderick  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
PlatformVS CodeOSWindows 10OS Version1909
Product Version3.0.4 
Summary0002003: Breakpoints and step-by-step debugging in VS Code not working
DescriptionI have Open Server x64 with PHP8 -TS. I installed Xdebug v3, but it doesn't work adequately in VS Code, just ignoring breakpoints or - even better - swearing about missing mysqli module when debugging step by step. Apparently Xdebug is up and running because I see formatted error output in the browser when developer mode is enabled AND when xdebug_break () is added in code, but even so there are bugs in the work.
I also tried XAMPP on a completely clean system, but the result was exactly the same.
Switching to older versions of PHP and Xdebug (2.x .x) did not work.
Steps To Reproduce1) Install Open Server 5.3.8 PHP8-TS x64 or XAMPP PHP8-TS x64.
3) Install Xdebug 3.4 x64 TS
2) Install VS Code 1.58.2
3) Install VSC extension PHP Debug v1.17.0
4) Automatic generate launch.json
5) Strart debug(?)
Additional InformationPhotos are not uploaded to the site, so I am attaching a link to google drive:
https://drive.google.com/drive/u/0/folders/1Uarfc3AmNNr7m531fa3ejnBzGa7Nk6KC
Tagsphp8.0, visual-studio-code, windows
Operating System
PHP Version8.0.0-8.0.4

Activities

jekpad

2021-08-01 16:26

reporter   ~0005951

After spending all day, I came to a partial solution to the problem:
• Add xdebug_break () to the beginning of the script, after which you can debug step by step in the Listen for Xdebug mode, but you need to switch to the browser and press F5 each time;
• Work on the built-in administrator account and open the virtual disk partition in the IDE every time - otherwise the function above will stop working, and plus it will generate write errors due to the alleged absence of a file. Both Open Server and XAMPP hide the virtual disk for other users, even if they are administrators.
• Either disable the creation of a virtual hard disk to prevent its creation.

At the same time, debugging Launch currently open script is still not available.

derick

2021-08-06 17:44

administrator   ~0005960

Debugging with Xdebug and VS Code most definitely works. There is likely be something in your set up that is wrong. As this is not a support forum, I'd kindly point you to the support options that are available: https://xdebug.org/support

Issue History

Date Modified Username Field Change
2021-08-01 15:12 jekpad New Issue
2021-08-01 15:12 jekpad Tag Attached: php8.0
2021-08-01 15:12 jekpad Tag Attached: visual-studio-code
2021-08-01 15:12 jekpad Tag Attached: windows
2021-08-01 16:26 jekpad Note Added: 0005951
2021-08-06 17:44 derick Assigned To => derick
2021-08-06 17:44 derick Status new => resolved
2021-08-06 17:44 derick Resolution open => no change required
2021-08-06 17:44 derick Note Added: 0005960