View Issue Details

IDProjectCategoryView StatusLast Update
0000239XdebugUsage problems (Wrong Results)public2007-02-17 21:20
ReporterbhofmannAssigned Toderick 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0000239: Strings with null chars are not fully sent to the client
DescriptionThe bug n°0000228 is marked as closed but I still have it with the 2007-02-02 build from pecl
TagsNo tags attached.
Operating System
PHP Version5.1.6

Activities

derick

2007-02-09 20:48

administrator   ~0000562

I can not reproduce this with Xdebug-2.0.0rc4-dev with the script from that bug report. It correctly replies:

(cmd) property_get -i 3 -n $a
<?xml version="1.0" encoding="iso-8859-1"?>
<response command="property_get" transaction_id="3"><property name="$a" fullname="$a" address="-1215898560" type="string" size="36" encoding="base64"><![CDATA[aGVsbG8KRGF2ZQBJIGhhdmUgYWRkZWQgYSBudWxsAG9yIDIK]]></property></response>

Please provide a script and which commands you are sending to the debug client so that I can reproduce it.

bhofmann

2007-02-12 10:13

reporter   ~0000565

I tested it again with the new build from pecl from yesterday and it worked fine, sorry for the bogus report

derick

2007-02-17 21:20

administrator   ~0000566

Okay, marking as "not a bug" then.

Issue History

Date Modified Username Field Change
2007-02-09 09:51 bhofmann New Issue
2007-02-09 20:48 derick Note Added: 0000562
2007-02-09 20:48 derick Status new => feedback
2007-02-12 10:13 bhofmann Note Added: 0000565
2007-02-17 21:20 derick Status feedback => resolved
2007-02-17 21:20 derick Resolution open => no change required
2007-02-17 21:20 derick Assigned To => derick
2007-02-17 21:20 derick Note Added: 0000566
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)