View Issue Details

IDProjectCategoryView StatusLast Update
0000358XdebugUsage problems (Wrong Results)public2009-03-31 09:28
ReporterpengYouAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version 
Target VersionFixed in Version 
Summary0000358: xdebug segfaults with php-java-bridge's java.so
DescriptionWhen using xdebug in conjunction with php-java-bridge's java.so xdebug reproducibly segfaults. Email concerning this already have been exchanged on the xdebug mailing list.
Additional InformationReminder:

0000002 0x00002ad745582ac5 in zm_activate_java (type=<value optimized out>, module_number=1156960608) at /home/sdev/src/php-java-bridge/java.c:159
159 zend_execute(ar TSRMLS_CC);
(gdb) list
154 }
155 if(!ar) abort();
156 EG(return_value_ptr_ptr) = &result;
157 current = EG(active_op_array);
158 EG(active_op_array) = ar;
159 zend_execute(ar TSRMLS_CC);
160 #if 1
161 destroy_op_array(ar TSRMLS_CC);
162 efree(ar);
163 ar = 0;
(gdb)
TagsNo tags attached.
Operating SystemLinux
PHP Version5.2.5

Relationships

has duplicate 0000435 resolvedderick php segmentation fault with enabled xdebug 

Activities

tkeller

2008-07-09 16:36

reporter   ~0000865

Hi Marcus!

Sorry for being off-topic here, but I'm experiencing the same problem (luckily I do not need to profile a script which needs the bridge) - anyways - you mentioned in http://xdebug.org/archives/xdebug-general/1229.html that the usage of java.so is deprecated and that the development on the bridge is stalled. Since we've just started with a new project which uses the bridge, I'm a bit concerned about this comment actually - can you pinpoint me to a discussion or other ressource where you got these information?

Thanks in advance,
Thomas.

derick

2009-03-28 17:30

administrator   ~0000932

I can't fix this as I can't find the source code for the java bridge, and thus not reproduce this problem.

pengYou

2009-03-31 09:08

reporter   ~0000949

Last edited: 2009-03-31 09:10

Sorry for answering this late, Thomas.
Just to document this in case someone stumbles over this thread: the php-java-bridge is still under very active development as of today as one can easily see at the bridge's site at http://php-java-bridge.sourceforge.net/. I was just refering to the bridge's java.so which by now is no longer available.

@Derick: I remember at the time we exchanged emails you said you wanted to fix this bug independently of the bridge, so here are all the source files i could dig up at a sourceforge mirror: http://mirror.optus.net/sourceforge/p/ph/php-java-bridge/. It was version 4.3.2 ff. that caused the segfault.

Please note that imho there is no need to reopen this thread. The bridge now handles all php-related stuff via a native Java.inc script which can easily be cached by opcode caches.

derick

2009-03-31 09:28

administrator   ~0000950

I just had a chat with some of the other people that know the Zend Engine. Running zend_execute() from RINIT is never going to work reliably. As this is fixed in the java bridge, and you shouldn't do this anyway, I'm going to close this issue again.

Issue History

Date Modified Username Field Change
2008-03-20 15:18 pengYou New Issue
2008-07-09 16:36 tkeller Note Added: 0000865
2009-03-28 17:26 derick Relationship added has duplicate 0000435
2009-03-28 17:30 derick Note Added: 0000932
2009-03-28 17:30 derick Status new => resolved
2009-03-28 17:30 derick Resolution open => not fixable
2009-03-28 17:30 derick Assigned To => derick
2009-03-31 09:08 pengYou Note Added: 0000949
2009-03-31 09:08 pengYou Status resolved => feedback
2009-03-31 09:08 pengYou Resolution not fixable => reopened
2009-03-31 09:10 pengYou Note Edited: 0000949
2009-03-31 09:28 derick Note Added: 0000950
2009-03-31 09:28 derick Status feedback => resolved
2009-03-31 09:28 derick Resolution reopened => won't fix
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)