View Issue Details

IDProjectCategoryView StatusLast Update
0000435Xdebug(No Category)public2009-03-28 17:26
ReportergunzipAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityN/A
Status resolvedResolutionduplicate 
Product Version2.0.0dev 
Target VersionFixed in Version 
Summary0000435: php segmentation fault with enabled xdebug
Descriptionhello, i'm using xdebug with php-5.2.4-2ubuntu5.5

i've tried with the ubuntu repository xdebug package first, then i compiled latest cvs xdebug myself but i always get a segmentation fault running php if i enable xdebug in the php.ini (zend_extension="/usr/lib/php5/20060613+lfs/xdebug.so"). it segfaults from the cli and from apache too.
Additional Informationore was generated by `php -v'.
Program terminated with signal 11, Segmentation fault.
[New process 17532]
#0 0xb775ac98 in add_stack_frame (zdata=0x0, op_array=0x86a7160, type=2) at /root/xdebug/xdebug.c:1262
1262 if (XDEBUG_LLIST_TAIL(XG(stack))) {
(gdb) bt
#0 0xb775ac98 in add_stack_frame (zdata=0x0, op_array=0x86a7160, type=2) at /root/xdebug/xdebug.c:1262
#1 0xb775bcd2 in xdebug_execute (op_array=0x86a7160) at /root/xdebug/xdebug.c:1539
0000002 0xb7283f9c in zm_activate_java () from /usr/lib/php5/20060613+lfs/java.so
0000003 0x082c86c1 in module_registry_request_startup ()
0000004 0x082cf4cc in zend_hash_apply ()
0000005 0x082c45aa in zend_activate_modules ()
0000006 0x0827b2da in php_request_startup ()
0000007 0x083557a5 in main ()
TagsNo tags attached.
Operating SystemLinux ubuntu
PHP Version5.2.4

Relationships

duplicate of 0000358 resolvedderick xdebug segfaults with php-java-bridge's java.so 

Activities

gunzip

2009-03-27 17:05

reporter   ~0000927

ok just discovered the issue happens only if php-java-bridge is enabled too.
maybe there's an incompatibility between the two modules ?

derick

2009-03-28 17:26

administrator   ~0000931

Duplicate of bug 0000358.

Issue History

Date Modified Username Field Change
2009-03-27 17:01 gunzip New Issue
2009-03-27 17:01 gunzip Operating System => Linux ubuntu
2009-03-27 17:01 gunzip PHP Version => 5.2.4
2009-03-27 17:01 gunzip Xdebug Version => 2.0.4-dev
2009-03-27 17:05 gunzip Note Added: 0000927
2009-03-28 17:26 derick Note Added: 0000931
2009-03-28 17:26 derick Relationship added duplicate of 0000358
2009-03-28 17:26 derick Duplicate ID 0 => 358
2009-03-28 17:26 derick Status new => resolved
2009-03-28 17:26 derick Resolution open => duplicate
2009-03-28 17:26 derick Assigned To => derick
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)