View Issue Details

IDProjectCategoryView StatusLast Update
0000365XdebugFeature/Change requestpublic2016-12-13 21:34
ReporterderickAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0000365: Feature patch, allow code coverage to avoid "covering" certain files by path.
DescriptionAdds a new userspace command to the code coverage section:-

void xdebug_code_coverage_exclude_paths (array);

Basically, passes an array of strings that the coverage should avoid counting on. The strings are matched against the
filename path and if a match is made code coverage doesn't cover that module.

Reasons for creating it. I have a rather heavy weight test syste to deal with against a rather large application and I
didn't want xdebug to code coverage the actual test scripts, just the application. Well, simple as that.

See: http://xdebug.org/archives/xdebug-general/1236.html
TagsNo tags attached.
Operating System
PHP Version5.2.5

Relationships

duplicate of 0001059 closedderick Add filter capabilities to tracing, stack traces, and code coverage. 

Activities

Milian Wolff

2008-07-03 22:47

reporter   ~0000858

Was able to compile it and call it from a PHP file. But it is not what I thought it would be. A pity ;-)

FWIW:

xdebug_code_coverage_exclude_paths(array(__FILE__));
xdebug_start_trace(__FILE__, XDEBUG_TRACE_COMPUTERIZED);

=> won't work as expected currently. Could you adapt your patch?

derick

2016-12-13 21:34

administrator   ~0004051

Duplicate of 0001059

Issue History

Date Modified Username Field Change
2008-04-18 18:24 derick New Issue
2008-07-03 22:47 Milian Wolff Note Added: 0000858
2016-12-13 21:34 derick Note Added: 0004051
2016-12-13 21:34 derick Relationship added duplicate of 0001059
2016-12-13 21:34 derick Status new => resolved
2016-12-13 21:34 derick Resolution open => duplicate
2016-12-13 21:34 derick Assigned To => derick