View Issue Details

IDProjectCategoryView StatusLast Update
0000504XdebugFeature/Change requestpublic2016-12-13 21:35
Reporterrene7705Assigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.0.0dev 
Target VersionFixed in Version 
Summary0000504: i'd like to be able to list a whitelist / blacklist of functions & classes for a trace / profiling
DescriptionFor my custom debugging system i need a full trace including full variable & return content.

But adding this for all functions will cause the logs to grow so large that parsing them will become (too) slow.

so i'd like to propose adding a few parameters somewhere (preferably also in xdebug_start_trace());

- whitelist of classes to include in a log (so excluding all others)
- blacklist of classes not to include in a log
- whitelist of functions to include in a log (so excluding all others)
- blacklist of functions not to include in a log
(if a whitelist is set, the blacklist is irrelevant, imo)
 
It would be great if you could also add a function that returns which classes and functions are in a given php file.
I'm willing to write this last one (in php), if you're interested in adding these white- & blacklists.

TagsNo tags attached.
Operating Systemn/a
PHP Version5.2.10

Relationships

duplicate of 0001059 closedderick Add filter capabilities to tracing, stack traces, and code coverage. 

Activities

derick

2016-12-13 21:35

administrator   ~0004052

Duplicate of 0001059.

Issue History

Date Modified Username Field Change
2009-12-27 07:19 rene7705 New Issue
2009-12-27 07:19 rene7705 Operating System => n/a
2009-12-27 07:19 rene7705 PHP Version => 5.2.10
2009-12-27 07:19 rene7705 Xdebug Version => 2.0.5
2016-12-13 21:35 derick Note Added: 0004052
2016-12-13 21:35 derick Relationship added duplicate of 0001059
2016-12-13 21:35 derick Status new => resolved
2016-12-13 21:35 derick Resolution open => duplicate
2016-12-13 21:35 derick Assigned To => derick