View Issue Details

IDProjectCategoryView StatusLast Update
0000554Xdebug(No Category)public2010-03-31 17:57
ReporterflixfeAssigned Toderick 
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0000554: xdebug-2.0.5: apache segfault on any PHP page
DescriptionRunning the latest stable apache on gentoo (2.2.14-r1) and xdebug 2.0.5 results in a segfault every time I access any php page. Apache's error log shows:

[notice] child pid 24697 exit signal Segmentation fault (11)

This happens even on simple script which just calls phpinfo();

I've set apache to 1 thread and caught a backtrace with gdb:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fda2f131910 (LWP 24996)]
0x00007fda2fb6226d in xdebug_init_oparray (op_array=0x170d878) at
3156 /var/tmp/portage/dev-php5/xdebug-2.0.5/work/xdebug-2.0.5/xdebug.c: No
such file or directory.
        in /var/tmp/portage/dev-php5/xdebug-2.0.5/work/xdebug-2.0.5/xdebug.c
(gdb) bt
#0 0x00007fda2fb6226d in xdebug_init_oparray (op_array=0x170d878) at
#1 0x00007fda334cc9bb in zend_extension_op_array_ctor_handler
(extension=0x1500e30, op_array=0x170d878, tsrm_ls=0x16e9330)
0000002 0x00007fda334cc67a in zend_llist_apply_with_argument (l=0x7fda33a7aec0,
func=0x7fda334cc98c <zend_extension_op_array_ctor_handler>, arg=0x170d878,
    tsrm_ls=0x16e9330) at
0000003 0x00007fda334ccca4 in init_op_array (op_array=0x170d878, type=2 '\002',
initial_ops_size=64, tsrm_ls=0x16e9330)
0000004 0x00007fda3349cbf9 in compile_file (file_handle=0x7fda2f130e70, type=8,
0000005 0x00007fda2fb5f69c in xdebug_compile_file (file_handle=0x7fda2f130e70,
type=8, tsrm_ls=0x16e9330)
    at /var/tmp/portage/dev-php5/xdebug-2.0.5/work/xdebug-2.0.5/xdebug.c:2405
0000006 0x00007fda334daa63 in zend_execute_scripts (type=8, tsrm_ls=0x16e9330,
retval=0x0, file_count=3)
    at /var/tmp/portage/dev-lang/php-5.2.12/work/php-5.2.12/Zend/zend.c:1126
0000007 0x00007fda33466956 in php_execute_script (primary_file=0x7fda2f130e70,
    at /var/tmp/portage/dev-lang/php-5.2.12/work/php-5.2.12/main/main.c:2036
0000008 0x00007fda33570786 in php_handler (r=0x16ed9b8) at
0000009 0x0000000000439e02 in ap_run_handler (r=0x16ed9b8) at config.c:158
0000010 0x000000000043d31f in ap_invoke_handler (r=0x16ed9b8) at config.c:372
0000011 0x0000000000448028 in ap_process_request (r=0x16ed9b8) at
0000012 0x0000000000445108 in ap_process_http_connection (c=0x16e9bb0) at
0000013 0x0000000000441242 in ap_run_process_connection (c=0x16e9bb0) at
0000014 0x000000000044d471 in process_socket (thd=0x14041d8, dummy=<value optimized
out>) at worker.c:544
0000015 worker_thread (thd=0x14041d8, dummy=<value optimized out>) at worker.c:894
0000016 0x00007fda392aa2a7 in start_thread () from /lib/
0000017 0x00007fda38e166ad in clone () from /lib/
0000018 0x0000000000000000 in ?? ()
TagsNo tags attached.
Operating Systemgentoo linux
PHP Version5.2.10



2010-03-31 08:12

administrator   ~0001412

Please try the latest version from SVN:


2010-03-31 17:08

reporter   ~0001414

Unfortunately I'm not able to build xdebug (revision 3241) according to the instructions from the README due to some libtool error:

~/temp/xdebug $ phpize
Configuring for:
PHP Api Version: 20041225
Zend Module Api No: 20060613
Zend Extension Api No: 220060519

~/temp/xdebug $ ./configure --enable-xdebug

~/temp/xdebug $ make
bin/sh /home/felix/temp/xdebug/libtool --mode=compile cc -I. -I/home/felix/temp/xdebug -DPHP_ATOM_INC -I/home/felix/temp/xdebug/include -I/home/felix/temp/xdebug/main -I/home/felix/temp/xdebug -I/usr/lib64/php5/include/php -I/usr/lib64/php5/include/php/main -I/usr/lib64/php5/include/php/TSRM -I/usr/lib64/php5/include/php/Zend -I/usr/lib64/php5/include/php/ext -I/usr/lib64/php5/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O0 -c /home/felix/temp/xdebug/xdebug.c -o xdebug.lo
/home/felix/temp/xdebug/libtool: line 467: CDPATH: command not found
/home/felix/temp/xdebug/libtool: line 1152: func_opt_split: command not found
libtool: Version mismatch error. This is libtool 2.2.6b, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.6b
libtool: and run autoconf again.
make: *** [xdebug.lo] Error 63

This is a gentoo system using libtool 2.2.6b. I also tried with libtool 1.5.26 but the error was the same.

I tried getting around this problem by removing aclocal.m4 and running libtoolize and autoreconf, but the error remains.

Not sure how to get xdebug built.


2010-03-31 17:14

administrator   ~0001415

Did you install PHP yourself or through the emerge stuff?


2010-03-31 17:16

reporter   ~0001416

OK ... I found a way to build it :-)
I just modified the xdebug-2.0.5 ebuild from gentoo to use the latest SVN and it build just fine.

Going to test that version now.


2010-03-31 17:16

reporter   ~0001417

I installed php through the 'emerge stuff' ;-)


2010-03-31 17:25

reporter   ~0001418

Great news: it works with the current SVN snapshot.
Looks like a great tool, btw, thanks for your efforts.
Please close this bug (Mantis doesn't seem to allow me to do this).


2010-03-31 17:28

reporter   ~0001419

BTW, the downstream bug report is:


2010-03-31 17:57

administrator   ~0001420

Closing then, thanks for testing!

Issue History

Date Modified Username Field Change
2010-03-30 18:24 flixfe New Issue
2010-03-30 18:24 flixfe Operating System => gentoo linux
2010-03-30 18:24 flixfe PHP Version => 5.2.10
2010-03-30 18:24 flixfe Xdebug Version => 2.0.5
2010-03-31 08:12 derick Note Added: 0001412
2010-03-31 08:12 derick Status new => feedback
2010-03-31 17:08 flixfe Note Added: 0001414
2010-03-31 17:14 derick Note Added: 0001415
2010-03-31 17:16 flixfe Note Added: 0001416
2010-03-31 17:16 flixfe Note Added: 0001417
2010-03-31 17:25 flixfe Note Added: 0001418
2010-03-31 17:28 flixfe Note Added: 0001419
2010-03-31 17:57 derick Note Added: 0001420
2010-03-31 17:57 derick Status feedback => resolved
2010-03-31 17:57 derick Resolution open => no change required
2010-03-31 17:57 derick Assigned To => derick
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)