View Issue Details

IDProjectCategoryView StatusLast Update
0000582XdebugUsage problems (Wrong Results)public2010-07-23 23:45
ReporterHubbitusAssigned Toderick 
Status resolvedResolutionno change required 
Product Version2.0.0dev 
Target VersionFixed in Version 
Summary0000582: php 5.3 crached with xdebug 2.0.5
DescriptionIt always crashes near to start of debug session. After hit one or two breakpoint.

Problem always reproduced.
Additional InformationI have tried get backtrace by get coredump (from howto
$ echo "/tmp/core-%e.%p" > /proc/sys/kernel/core_pattern
$ ulimit -c unlimited
# service httpd restart

and run it from GDB:
# gdb httpd.itk

# gdb httpd.itk
GNU gdb (GDB) Red Hat Enterprise Linux (7.0.1-23.el5)
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu".
For bug reporting instructions, please see:
Reading symbols from /usr/sbin/httpd.itk...(no debugging symbols found)...done.
(gdb) run -X -DNO_DETACH
Starting program: /usr/sbin/httpd.itk -X -DNO_DETACH
[Thread debugging using libthread_db enabled]
Detaching after fork from child process 26415.

Program exited with code 01.
(gdb) quit
[root@cos1 conf]#

With no success. Please, can you say what I do wrong and how I can help debug this issue?
TagsNo tags attached.
Operating SystemCentOS Linux 5.5
PHP Version5.3.2



2010-05-16 23:57

administrator   ~0001482

Please try the latest RC from and see if that works.


2010-05-17 09:01

reporter   ~0001483

2.1.0RC1 seams segfaulted on the same manner. May be it live on few seconds longer and 3-4 debug steps may be accomplished...


2010-05-17 09:06

reporter   ~0001484

Now I downgrade php to 5.2.10 version and on it both versions of xdebug works fine.


2010-05-17 14:11

administrator   ~0001485

Please make a proper backtrace then, as yours doesn't show anything useful. Try with PHP 5.3 and the 2.1.0RC1 though! See the instructions at under "If you can't get a core file"


2010-05-17 14:29

reporter   ~0001486

Probably the same issue, Ubuntu 10.04. Test case:



function whatever() {};

Core was generated by `php testcase.php'.
Program terminated with signal 11, Segmentation fault.
#0 0x009da785 in ?? () from /lib/tls/i686/cmov/
(gdb) bt
#0 0x009da785 in ?? () from /lib/tls/i686/cmov/
#1 0x0825f45c in php_addcslashes (str=0x17b0af43 <Address 0x17b0af43 out of bounds>, length=0, new_length=0xbfcf3624, should_free=0, what=0x3f22ea "'\\", wlength=6)
    at /build/buildd/php5-5.3.2/ext/standard/string.c:3121
0000002 0x003e6b0a in xdebug_var_export (struc=0xbfcf3680, str=0xbfcf3660, level=1, debug_zval=0, options=0xa941e28) at /build/buildd/xdebug-2.0.5/build-php5/xdebug_var.c:283
0000003 0x003e6fc6 in xdebug_get_zval_value (val=0xa8cfe70, debug_zval=0, options=0xa941e28) at /build/buildd/xdebug-2.0.5/build-php5/xdebug_var.c:365
0000004 0x003cd985 in add_stack_frame (zdata=0xa901824, op_array=0xa8d0bcc, type=2) at /build/buildd/xdebug-2.0.5/build-php5/xdebug.c:1081
0000005 0x003cee3f in xdebug_execute (op_array=0xa8d0bcc) at /build/buildd/xdebug-2.0.5/build-php5/xdebug.c:1512
0000006 0x08348c36 in ZEND_INCLUDE_OR_EVAL_SPEC_VAR_HANDLER (execute_data=0xa901824) at /build/buildd/php5-5.3.2/Zend/zend_vm_execute.h:8576
0000007 0x08333d8e in execute (op_array=0xa8d044c) at /build/buildd/php5-5.3.2/Zend/zend_vm_execute.h:104
0000008 0x003cf015 in xdebug_execute (op_array=0xa8d044c) at /build/buildd/xdebug-2.0.5/build-php5/xdebug.c:1562
0000009 0x08309fa6 in zend_execute_scripts (type=8, retval=0x0, file_count=3) at /build/buildd/php5-5.3.2/Zend/zend.c:1266
0000010 0x082ae754 in php_execute_script (primary_file=0xbfcf5e14) at /build/buildd/php5-5.3.2/main/main.c:2288
0000011 0x083a0c28 in main (argc=2, argv=0xbfcf5f54) at /build/buildd/php5-5.3.2/sapi/cli/php_cli.c:1196


2010-06-21 21:44

reporter   ~0001498

I had a similar problem with the released version of XDebug on windows 7, using php 5.3.2 on Apache and IIS. It made my scripts crash with a weird error in the browser, stating that the request was reinitialized and the browser only showing that warning.

Because I found this entry here I tried the RC1 version as Derick recommended and it worked just fine. It took me quite some time to figure out why it wasn't working, because I never bothered to install XDebug before. Now that I did, I am quite happy and I hope this will help someone else who has the same problem.

Thanks Derick!


2010-07-01 14:41

reporter   ~0001511

The same issue. I use Fedora 13, PHP 5.3.2. Crash reproduced on XDebug 2.0.5 and 2.1.0RC1.

*** glibc detected *** httpd: double free or corruption (!prev): 0x00007f3eeced4890 ***
======= Backtrace: =========


2010-07-23 23:45

administrator   ~0001544

OP didn't provide feedback, and I can't reproduce this with latest SVN.

Issue History

Date Modified Username Field Change
2010-05-16 23:04 Hubbitus New Issue
2010-05-16 23:04 Hubbitus Operating System => CentOS Linux 5.5
2010-05-16 23:04 Hubbitus PHP Version => 5.3.2
2010-05-16 23:04 Hubbitus Xdebug Version => 2.0.5
2010-05-16 23:57 derick Note Added: 0001482
2010-05-16 23:57 derick Status new => feedback
2010-05-17 09:01 Hubbitus Note Added: 0001483
2010-05-17 09:06 Hubbitus Note Added: 0001484
2010-05-17 14:11 derick Note Added: 0001485
2010-05-17 14:29 kaliber Note Added: 0001486
2010-06-21 21:44 mcleod Note Added: 0001498
2010-07-01 14:41 lexaa Note Added: 0001511
2010-07-23 23:45 derick Note Added: 0001544
2010-07-23 23:45 derick Status feedback => resolved
2010-07-23 23:45 derick Resolution open => no change required
2010-07-23 23:45 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)