View Issue Details

IDProjectCategoryView StatusLast Update
0000586XdebugUsage problems (Wrong Results)public2010-06-16 15:17
ReporterchambyAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0000586: eval() with base64_decode causes segfault
Description<?php
    //echo base64_encode('printf("output text");'); // Generates the string used below
    eval(base64_decode('cHJpbnRmKCJvdXRwdXQgdGV4dCIpOw==')); // Should print 'output text'
?>

(gdb) bt
#0 0x00007f2c59235022 in ?? () from /lib/libc.so.6
#1 0x00000000005f9e59 in php_addcslashes (str=0x3c0656d988681c07 <Address 0x3c0656d988681c07 out of bounds>, length=0, new_length=0x0, should_free=1, what=0x7f2c581cdaea "'\\", wlength=6)
    at /build/buildd/php5-5.3.2/ext/standard/string.c:3121
0000002 0x00007f2c581c1acb in xdebug_var_export (struc=0x7fff8205e3b8, str=0x7fff8205e3c0, level=1, debug_zval=0, options=0x1585090) at /build/buildd/xdebug-2.0.5/build-php5/xdebug_var.c:283
0000003 0x00007f2c581c1f8e in xdebug_get_zval_value (val=0x155bd10, debug_zval=0, options=0x1585090) at /build/buildd/xdebug-2.0.5/build-php5/xdebug_var.c:365
0000004 0x00007f2c581a727e in add_stack_frame (zdata=0x7f2c5bdbb068, op_array=0x155d238, type=2) at /build/buildd/xdebug-2.0.5/build-php5/xdebug.c:1081
0000005 0x00007f2c581a8984 in xdebug_execute (op_array=0x155d238) at /build/buildd/xdebug-2.0.5/build-php5/xdebug.c:1512
0000006 0x00000000006d165c in ZEND_INCLUDE_OR_EVAL_SPEC_VAR_HANDLER (execute_data=0x7f2c5bdbb068) at /build/buildd/php5-5.3.2/Zend/zend_vm_execute.h:8576
0000007 0x00000000006bd400 in execute (op_array=0x155c710) at /build/buildd/php5-5.3.2/Zend/zend_vm_execute.h:104
0000008 0x00007f2c581a8b9e in xdebug_execute (op_array=0x155c710) at /build/buildd/xdebug-2.0.5/build-php5/xdebug.c:1562
0000009 0x000000000069512d in zend_execute_scripts (type=0, retval=0x7fff8205e920, file_count=3) at /build/buildd/php5-5.3.2/Zend/zend.c:1266
0000010 0x0000000000640d98 in php_execute_script (primary_file=0x2) at /build/buildd/php5-5.3.2/main/main.c:2288
0000011 0x0000000000726236 in main (argc=0, argv=0x1) at /build/buildd/php5-5.3.2/sapi/cli/php_cli.c:1196
Additional Informationsee https://bugs.launchpad.net/ubuntu/+source/php5/+bug/594696
TagsNo tags attached.
Operating SystemLinux - Ubuntu 10.04 LTS
PHP Version5.3.2

Activities

derick

2010-06-15 22:34

administrator   ~0001494

Please try Xdebug 2.1.0RC1 from http://xdebug.org/download.php, or rather, try it from SVN: http://xdebug.org/docs/install#source

chamby

2010-06-15 23:10

reporter   ~0001495

Unable to reproduce with SVN. I should build from source more often I guess. ;-)

derick

2010-06-16 15:17

administrator   ~0001496

awesome, closing then

Issue History

Date Modified Username Field Change
2010-06-15 19:14 chamby New Issue
2010-06-15 19:14 chamby Operating System => Linux - Ubuntu 10.04 LTS
2010-06-15 19:14 chamby PHP Version => 5.3.2
2010-06-15 19:14 chamby Xdebug Version => 2.0.5
2010-06-15 22:34 derick Note Added: 0001494
2010-06-15 22:35 derick Status new => feedback
2010-06-15 23:10 chamby Note Added: 0001495
2010-06-16 15:17 derick Note Added: 0001496
2010-06-16 15:17 derick Status feedback => resolved
2010-06-16 15:17 derick Resolution open => no change required
2010-06-16 15:17 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)