View Issue Details

IDProjectCategoryView StatusLast Update
0000633XdebugUsage problems (Wrong Results)public2011-01-10 21:54
Reportermarian form uzbekistanAssigned Toderick 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
PlatformIntel i7 OSWindows 7OS Versionprofesional
Product Version2.1.0 
Target VersionFixed in Version 
Summary0000633: Variables not available in Eclipse/DebugPerspective/Variables view.
Descriptionphp_xdebug-2.1.0-5.3-vc6.dll downloaded form your website
eclipse galileo
PHP Version 5.3.1

Debuging works ( step in/out, breakpoints etc... ) but can't see any variables in variables eclipse view. It's empty. Breakpoint tab works fine.


Steps To Reproduce1. Open eclipse and appache on localhost.
2. set up debuging for some script, set a break point .
3. debug it and stop at breakpoint and check if you see any variables.

observed results:
no variables seen whatsoever.

expected variables:
all local objects, globals super-globals ought to be seen in variables view together with their fields.
Additional Informationit's pretty sad circumstances since the reason for debugging is to inspect the variables during runtime.
TagsNo tags attached.
Operating SystemWindows 7
PHP Version5.3.1

Activities

marian form uzbekistan

2010-11-01 20:17

reporter   ~0001597

I have upgraded the PHP version to 5.3.3 ( non thread safe VC6 compiled ) and the problem still exists.

marian form uzbekistan

2010-11-01 20:28

reporter   ~0001598

I have upgraded the PHP version to 5.3.3 ( non thread safe VC6 compiled ) AND RESTRTED ECLIPSE ;P and the problem gone. It works now.
so maybe php 5.3.1 and xdebug 2.1.0 doesn't mix together well.

fratilkus

2010-11-09 10:23

reporter   ~0001602

If you use binary indexes in arrays, xdebug want show variables
Example:
<?php
$index = chr(0);
$x = array( $index => 1, 2, 3 );
var_dump($x);
?>

Maybe this bug helps

dasjo

2010-11-15 14:00

reporter   ~0001613

same here with php 5.3.3 + xdebug 2.1.0 under ubuntu 9.10 in different eclipse & aptana versions

derick

2011-01-10 21:54

administrator   ~0001639

Closing this as it works for the original reporter.

@fratilkus: There is already another report for that: http://bugs.xdebug.org/view.php?id=650

@dasjo: Talk on the mailinglist, and provide there remote debug log from a small reproducable script. For a debug log, see: http://xdebug.org/docs/remote#remote_log

Issue History

Date Modified Username Field Change
2010-11-01 19:13 marian form uzbekistan New Issue
2010-11-01 20:17 marian form uzbekistan Note Added: 0001597
2010-11-01 20:28 marian form uzbekistan Note Added: 0001598
2010-11-09 10:23 fratilkus Note Added: 0001602
2010-11-15 14:00 dasjo Note Added: 0001613
2011-01-10 21:54 derick Note Added: 0001639
2011-01-10 21:54 derick Status new => resolved
2011-01-10 21:54 derick Resolution open => no change required
2011-01-10 21:54 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)