View Issue Details

IDProjectCategoryView StatusLast Update
0000650XdebugUncategorizedpublic2012-07-14 19:38
ReporterppislAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.1.0 
Target Version2.2.1Fixed in Version2.2.1 
Summary0000650: xdebug sends invalid xml character in certain case
DescriptionIt's reproducible when you try to debug this code:

define('EL_GAMMA', chr(hexdec('0x13')));
$arr = array(EL_GAMMA=>'?') ;

After debugging second line, the messages contains invalid characters. It's similar to the bug id 0000421.
Steps To ReproduceJust try to debug file
<?php
define('EL_GAMMA', chr(hexdec('0x13')));
$arr = array(EL_GAMMA=>'?') ;
echo "test";
?>
TagsNo tags attached.
Operating System
PHP Version5.3.3

Relationships

duplicate of 0000610 resolvedderick Xdebug sends invalid '&#0' char reference in response 
has duplicate 0000638 resolvedderick Do not show Variables in eclipse 

Activities

nexxer

2011-01-05 14:51

reporter   ~0001631

To add to this, xdebug also stops showing changes to variables or any new ones after encountering such a character. Step through:

define('EL_GAMMA', chr(hexdec('0x13')));

$var1 = 'hello' ;

$arr = array(EL_GAMMA=>'?') ;

$var2 = 'hi' ;
$var1 = 'changed?' ;

ppisl

2011-01-05 15:04

reporter   ~0001632

The problem mentioned by Nexxer is on the NetBeans site. xdebug sends the new variables, but because the message contains invalid xml character, NetBeans were not able to parse the xml and such message was not processed correctly. I have implemented workaround in NetBeans that removed all invalid characters from the xdebug message, so in NetBeans you should see new variables now (if you use a build with the fix (http://netbeans.org/bugzilla/show_bug.cgi?id=179309)).

nexxer

2011-01-05 16:08

reporter   ~0001633

Thanks for ppisl's fix this is not an issue anymore. Apologies for jumping the gun here.

Issue History

Date Modified Username Field Change
2011-01-05 12:47 ppisl New Issue
2011-01-05 14:51 nexxer Note Added: 0001631
2011-01-05 15:04 ppisl Note Added: 0001632
2011-01-05 16:08 nexxer Note Added: 0001633
2011-01-10 21:56 derick Relationship added has duplicate 0000638
2012-03-12 16:39 derick Target Version => 2.2.1
2012-06-27 21:15 derick Relationship added duplicate of 0000610
2012-06-27 21:15 derick Status new => resolved
2012-06-27 21:15 derick Resolution open => duplicate
2012-06-27 21:15 derick Assigned To => derick
2012-07-14 19:38 derick Fixed in Version => 2.2.1
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2020-03-12 16:35 derick Category Usage problems (Wrong Results) => Variable Display
2020-03-12 16:38 derick Category Variable Display => Uncategorized