View Issue Details

IDProjectCategoryView StatusLast Update
0000945XdebugInstallationpublic2013-05-18 21:23
ReporterdotnetCarpenter Assigned Toderick  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionno change required 
PlatformDarwin OSOS XOS Version10.7
Product Version2.2.2 
Summary0000945: configure uses wrong path to php
DescriptionWhen installing Xdebug on a machine with php pre-installed (like Mac OS X) you'll want to keep your own version of php separate from the Apple supplied one. On *nix system, the default way is to have your own version of php in the /usr/local/bin directory. The Xdebug install process ignore this practice and uses the version in /usr/bin instead. Subsequently, hooking Xdebug to the wrong php version/process.

I have MAMP installed and the steps to reproduce, assumes you have an installation of MAMP. This bug should be reproducible on any *nix machine, though.
Steps To ReproduceSymlink your php path to MAMP's php version:
ln -s /Applications/MAMP/bin/php/php5.4.10/bin/php /usr/local/bin/php

Follow the guide from http://xdebug.org/wizard.php
Additional InformationThis could be an issue in upstream phpize
TagsNo tags attached.
Operating SystemMac OS X 10.7.5 Lion
PHP Version5.4.10-5.4.14

Activities

derick

2013-05-07 07:37

administrator   ~0002456

This not a bug in anything. If you're trying to trick the PHP configure system then this is what you get. Simple provide --with-php-config=/correct/path/php-config to the ./configure command and it should work.

dotnetCarpenter

2013-05-07 16:46

reporter   ~0002459

Thanks Derrick. Could you document it, when analyzing the phpinfo and config path differs from /usr/bin?
On another note, ./configure --with-php-config=/Applications/MAMP/bin/php/php5.4.10/conf/php.ini does not work.

./configure --with-php-config=/Applications/MAMP/bin/php/php5.4.10/conf/php.ini
..
checking target system type... i386-apple-darwin11.4.2
configure: error: Cannot find php-config. Please use --with-php-config=PATH

I'm still confused to who is maintaining the configure script. Is it Xdebug or the PHP team?

derick

2013-05-18 21:23

administrator   ~0002471

The option doesn't take a php.ini file, it wants a path to "php-config". The configure script comes through phpize from the PHP build system.

Issue History

Date Modified Username Field Change
2013-05-06 16:44 dotnetCarpenter New Issue
2013-05-07 07:37 derick Note Added: 0002456
2013-05-07 07:37 derick Status new => resolved
2013-05-07 07:37 derick Resolution open => no change required
2013-05-07 07:37 derick Assigned To => derick
2013-05-07 16:46 dotnetCarpenter Note Added: 0002459
2013-05-07 16:46 dotnetCarpenter Status resolved => feedback
2013-05-07 16:46 dotnetCarpenter Resolution no change required => reopened
2013-05-18 21:23 derick Note Added: 0002471
2013-05-18 21:23 derick Status feedback => resolved
2013-05-18 21:23 derick Resolution reopened => no change required