View Issue Details

IDProjectCategoryView StatusLast Update
0000951XdebugUsage problems (Wrong Results)public2016-11-29 10:48
ReportergameshAssigned Toderick 
PrioritynormalSeveritycrashReproducibilitysometimes
Status resolvedResolutionunable to reproduce 
PlatformPHP 5.2.17OSWindows x64OS VersionServer 2008 R2
Product Version2.1.3 
Target VersionFixed in Version 
Summary0000951: when extension is loaded IIS crashed most of the time with 500 http code Error 0xC0000005
DescriptionTried with most recent version 2.2.3, also with 2.1.4 result is the same.
The FastCGI process crashes with error 0xC0000005.
This only happens when xdebug is loaded, attached crash report backtrace from Microsoft DebugDiag tool hope it helps.
Steps To ReproduceJust load xdebug extension and hit reload page multiple times and error appears.
Additional Informationxdebug cofniguration:
zend_extension=C:\php\ext\php_xdebug.dll
xdebug.cli_color=1
xdebug.show_local_vars=1
xdebug.remote_connect_back=1
xdebug.remote_enable=1
xdebug.idekey=netbeans-xdebug

PHP Version 5.2.17 VC9
IIS v7.5
Tagsiis, windows
Operating SystemWindows Server 2008 R2 Service Pack 1 x64
PHP Version5.2.10

Activities

gamesh

2013-06-19 12:35

reporter  

6Thread3952.htm (17,887 bytes)

najcik

2013-06-24 13:21

reporter   ~0002518

Do you run the Non-Thread-Safe version of the PHP and Xdebug as advised on the IIS site ?
Are there any errors when you run the php.exe from cmd prompt ?

gamesh

2013-06-25 05:18

reporter   ~0002521

xdebug and PHP versions are both NTS.
about php.exe from cmd errors, i'll check, but we don't realy use php cli

gamesh

2013-06-25 05:23

reporter   ~0002522

php-cli.exe also crashes:
Problem signature:
  Problem Event Name: APPCRASH
  Application Name: php.exe
  Application Version: 5.2.17.17
  Application Timestamp: 4d25fdfd
  Fault Module Name: ntdll.dll
  Fault Module Version: 6.1.7601.17725
  Fault Module Timestamp: 4ec49b8f
  Exception Code: c0000005
  Exception Offset: 0002e3be
  OS Version: 6.1.7601.2.1.0.274.10
  Locale ID: 1063
  Additional Information 1: 0a9e
  Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
  Additional Information 3: 0a9e
  Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

najcik

2013-06-28 10:03

reporter   ~0002526

Can you provide your php.ini

najcik

2013-06-28 10:05

reporter   ~0002527

If you can provide a snippet of PHP code that you try to run would be great.
Or does it happen regardless of code you try to run ?

gamesh

2013-06-28 10:14

reporter   ~0002528

it happens regardless of code. it just most of the time does crash if xdebug extension is loaded.

i don't know what else i can provide for you to easier trace back the problem,
if you do please let me know.

gamesh

2013-08-06 08:46

reporter  

error-log.txt (2,569 bytes)
-------------------------------------------------
Error:
-------------------------------------------------
Faulting application name: php-cgi.exe, version: 5.2.17.17, time stamp: 0x4d25fde8
Faulting module name: php5.dll, version: 5.2.17.17, time stamp: 0x4d25fd3b
Exception code: 0xc0000005
Fault offset: 0x00013905
Faulting process id: 0x1328
Faulting application start time: 0x01ce92808a16c172
Faulting application path: C:\php\php-cgi.exe
Faulting module path: C:\php\php5.dll
Report Id: d2211674-fe73-11e2-8e81-00155d1a5c0a

-------------------------------------------------
Details:
-------------------------------------------------
- System 

  - Provider 

   [ Name]  Application Error 
 
  - EventID 1000 

   [ Qualifiers]  0 
 
   Level 2 
 
   Task 100 
 
   Keywords 0x80000000000000 
 
  - TimeCreated 

   [ SystemTime]  2013-08-06T08:40:18.000000000Z 
 
   EventRecordID 619356 
 
   Channel Application 
 
   Computer srvituvstest.in.telecom.lt 
 
   Security 
 

- EventData 

   php-cgi.exe 
   5.2.17.17 
   4d25fde8 
   php5.dll 
   5.2.17.17 
   4d25fd3b 
   c0000005 
   00013905 
   1328 
   01ce92808a16c172 
   C:\php\php-cgi.exe 
   C:\php\php5.dll 
   d2211674-fe73-11e2-8e81-00155d1a5c0a 

-----------------------------------------
Error Information:
-------------------------------------------------
Fault bucket , type 0
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: php-cgi.exe
P2: 5.2.17.17
P3: 4d25fde8
P4: php5.dll
P5: 5.2.17.17
P6: 4d25fd3b
P7: c0000005
P8: 00013905
P9: 
P10: 

Attached files:

These files may be available here:


Analysis symbol: 
Rechecking for solution: 0
Report Id: d2211674-fe73-11e2-8e81-00155d1a5c0a
Report Status: 0
-------------------------------------------------
Details:
-------------------------------------------------
- System 

  - Provider 

   [ Name]  Windows Error Reporting 
 
  - EventID 1001 

   [ Qualifiers]  0 
 
   Level 4 
 
   Task 0 
 
   Keywords 0x80000000000000 
 
  - TimeCreated 

   [ SystemTime]  2013-08-06T08:40:18.000000000Z 
 
   EventRecordID 619357 
 
   Channel Application 
 
   Computer srvituvstest.in.telecom.lt 
 
   Security 
 

- EventData 

    
   0 
   APPCRASH 
   Not available 
   0 
   php-cgi.exe 
   5.2.17.17 
   4d25fde8 
   php5.dll 
   5.2.17.17 
   4d25fd3b 
   c0000005 
   00013905 
    
    
    
    
    
   0 
   d2211674-fe73-11e2-8e81-00155d1a5c0a 
   0    
   
error-log.txt (2,569 bytes)

gamesh

2013-08-06 08:46

reporter   ~0002552

Attached error report form Windows Error Event log

therochworks

2014-05-22 09:30

reporter   ~0002841

I have exactly the same issue with apache 2.2 and PHP 5.2.17 on Windows 7 (64Bit).
If I start the apache and load the first PHP script (maybe phpinfo()) a fatal error occurs with ntdll.dll error information.
I've tried TS with apache PHP module and NTS with FGCI allways the same problem.
Only if I use the xdebug version 2.1.2 (VC6) the issue doesn't occur.
On all VC9 versions the issue exists!

derick

2016-11-28 21:29

administrator   ~0003830

With the latest versions of PHP (7.0) and Xdebug (2.4.x), does this still cause a problem for you?

gamesh

2016-11-29 06:27

reporter   ~0003842

it's no longer relevant for me personaly, as we migrated away from IIS and PHP 5.2, to apache with php 5.5

derick

2016-11-29 10:48

administrator   ~0003846

Okay, thanks for letting me know. I'll be closing this then.

Please don't hesitate to open a new issue if you run into any. I'll promise to answer faster :-/

Issue History

Date Modified Username Field Change
2013-06-19 12:35 gamesh New Issue
2013-06-19 12:35 gamesh File Added: 6Thread3952.htm
2013-06-24 13:21 najcik Note Added: 0002518
2013-06-25 05:18 gamesh Note Added: 0002521
2013-06-25 05:23 gamesh Note Added: 0002522
2013-06-28 10:03 najcik Note Added: 0002526
2013-06-28 10:05 najcik Note Added: 0002527
2013-06-28 10:14 gamesh Note Added: 0002528
2013-08-05 10:34 gamesh Tag Attached: iis
2013-08-05 10:34 gamesh Tag Attached: windows
2013-08-06 08:46 gamesh File Added: error-log.txt
2013-08-06 08:46 gamesh Note Added: 0002552
2014-05-22 09:30 therochworks Note Added: 0002841
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2016-11-28 21:29 derick Note Added: 0003830
2016-11-28 21:29 derick Assigned To => derick
2016-11-28 21:29 derick Status new => feedback
2016-11-29 06:27 gamesh Note Added: 0003842
2016-11-29 06:27 gamesh Status feedback => assigned
2016-11-29 10:48 derick Note Added: 0003846
2016-11-29 10:48 derick Status assigned => resolved
2016-11-29 10:48 derick Resolution open => unable to reproduce