View Issue Details

IDProjectCategoryView StatusLast Update
0000965XdebugUsage problems (Wrong Results)public2016-11-29 23:52
ReporterzeranAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionno change required 
PlatformphpOSlinuxOS Versioncentos/ubuntu
Product Version2.2.3 
Target VersionFixed in Version 
Summary0000965: xdebug crash on trace
Descriptionxdebug crash on tracing code like
function test() {
return;
}
test(); // when returning null
and xdebug.collect_return=1
Tagscrash, null, return, trace
Operating Systemlinux
PHP Version5.3.10

Activities

derick

2013-07-23 10:51

administrator   ~0002542

When you say "tracing", what exactly do you mean? Can you elaborate a bit more please?

zeran

2013-07-23 11:41

reporter   ~0002544

I mean something like this:
function test() {
return;
}
xdebug_start_trace();
test(); // when returning null
xdebug_stop_trace();

and
xdebug.collect_return=1
in xdebug.ini
I think, xdebug trying collect return, but function returning "null", so xdebug crashing with error.

patomas

2014-02-02 01:12

reporter   ~0002673

Hi

I was having some problems with phpmyadmin, and after different attempts, I found that if I changed xdebug.collect_return="1" to xdebug.collect_return="0", everything went back to normal.

The problem was that many links didn't work and the session restarted sometimes, but I couldn't find any log that helped from mysql or phpmyadmin.

I'm posting the link to the thread since I explained the problem quite detailed there.

In any case, I'll post my system specs here:

- xdebug 2.2.3
- apache 2.2.25
- php 5.5.7
- mariadb 5.5.32
- mysql 5.1.70 and 5.5.32
- mysql-workbench 5.2.47
- system: Linux patito 3.10.7-gentoo 0000007 SMP Sun Sep 29 10:24:32 MYT 2013 x86_64 Intel(R) Core(TM) i5-3330 CPU @ 3.00GHz GenuineIntel GNU/Linux

I'm also uploading my xdebug.ini for reference.

stackoverflow question
https://stackoverflow.com/questions/21482099/problems-with-database-links-on-phpmyadmin-interfaceI

patomas

2014-02-02 01:13

reporter  

xdebug.ini (1,502 bytes)

steffenb

2014-08-07 06:48

reporter   ~0002875

I can confirm this bug.

After upgrading to Ubuntu 14.04, I had to turn off the xdebug.collect_return or my Apache would always segfault.
My system only has packages from standard repository.

Specs:
- Ubuntu 14.04 (Both server and desktop)
- apache2 2.4.7-1ubuntu4.1
- php5 5.5.9+dfsg-1ubuntu4.3
- php5-xdebug 2.2.3-2build1
- Kernel: Linux 3.13.0-30-generic 0000054-Ubuntu SMP Mon Jun 9 22:45:01 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

derick

2014-11-11 19:49

administrator   ~0002896

Is this still an issue with Xdebug 2.2.5 and the other latest versions?

patomas

2014-11-11 20:34

reporter   ~0002907

I can´t test that right now since I´m traveling, but in 3 weeks I can do it and report back.

tautrimas

2015-01-02 09:53

reporter   ~0002949

I could confirm the bug on 2.2.5 (segfault), but on 2.2.6 it has been fixed and "collect_return" acts normally as it should.

derick

2016-11-29 23:52

administrator   ~0003853

I'm expecting this one to be fixed. Please reopen this issue if you can reproduce this with the latest versions of Xdebug and PHP.

Issue History

Date Modified Username Field Change
2013-07-18 12:40 zeran New Issue
2013-07-18 12:41 zeran Tag Attached: trace
2013-07-18 12:41 zeran Tag Attached: crash
2013-07-18 12:41 zeran Tag Attached: null
2013-07-18 12:41 zeran Tag Attached: return
2013-07-23 10:51 derick Note Added: 0002542
2013-07-23 10:51 derick Assigned To => derick
2013-07-23 10:51 derick Status new => feedback
2013-07-23 11:41 zeran Note Added: 0002544
2013-07-23 11:41 zeran Status feedback => assigned
2014-02-02 01:12 patomas Note Added: 0002673
2014-02-02 01:13 patomas File Added: xdebug.ini
2014-08-07 06:48 steffenb Note Added: 0002875
2014-11-11 19:49 derick Note Added: 0002896
2014-11-11 19:49 derick Status assigned => feedback
2014-11-11 20:34 patomas Note Added: 0002907
2015-01-02 09:53 tautrimas Note Added: 0002949
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2016-11-29 23:52 derick Note Added: 0003853
2016-11-29 23:52 derick Status feedback => resolved
2016-11-29 23:52 derick Resolution open => no change required