MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001460XdebugUsage problems (Wrong Results)public2017-08-08 12:362017-08-08 14:06
Reporterrinu 
Assigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
StatusassignedResolutionopen 
PlatformOSUbuntuOS Version16.04
Product Version 
Target VersionFixed in Version 
Summary0001460: ext/opcache/Optimizer/dce.c:584: dce_live_ranges: Assertion `op_array->opcodes[def].result_type & ((1<<1)|(1<<2))' failed.
DescriptionXdebug (master branch) compiles and installs ok with PHP 7.2 but running any non-trivial code under FPM will result in this error, making PHP unusable.
TagsNo tags attached.
Operating System
PHP Version7.2-dev
Attached Files

- Relationships

-  Notes
(0004390)
derick (administrator)
2017-08-08 12:40

I'm going to need a back trace, and the smallest bit of code you can produce that triggers this (on the CLI) please.

Information on how to make a backtrace is at https://bugs.php.net/bugs-generating-backtrace.php [^]

Please run "export USE_ZEND_ALLOC=0" on the shell first, before "php script-that-crashes.php".
(0004391)
rinu (reporter)
2017-08-08 13:46

Cannot reproduce in CLI mode, only FPM.
When I try starting FPM manually, I get this:
ext/opcache/ZendAccelerator.c:634: accel_replace_string_by_process_permanent: Assertion `0' failed.

The "Generic way to get a core on Linux" has never worked for me. No idea why. So starting FPM manually with gdb was my only chance for backtrace.

When FPM runs as a service, this code will reproduce the original crash:
<?php
class test {
    protected $type;
    protected static $instances = [];

    public function __construct($type) {
        $this->type = $type;
    }

    public static function getInstance($type) {
        self::$instances[$type] = new self($type);
        return self::$instances[$type];
    }
}
test::getInstance('foo');
(0004392)
derick (administrator)
2017-08-08 13:52

Getting a back trace can indeed be fiddly - as you say you have one, did you forget to attach it to the report?
(0004393)
rinu (reporter)
2017-08-08 14:06

I didn't get a bt for this crash but I reported a php bug for the next issue I found here: https://bugs.php.net/bug.php?id=75048 [^]

How am I going to get a bt for this issue? I ran FPM with gdb and only got the bt for the other issue, not this one.

- Issue History
Date Modified Username Field Change
2017-08-08 12:36 rinu New Issue
2017-08-08 12:40 derick Note Added: 0004390
2017-08-08 12:40 derick Assigned To => derick
2017-08-08 12:40 derick Status new => feedback
2017-08-08 13:46 rinu Note Added: 0004391
2017-08-08 13:46 rinu Status feedback => assigned
2017-08-08 13:52 derick Note Added: 0004392
2017-08-08 14:06 rinu Note Added: 0004393


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker