View Issue Details

IDProjectCategoryView StatusLast Update
0001939XdebugStep Debuggingpublic2021-05-21 13:20
Reporterbergafabio Assigned Toderick  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformwindowsOSWIndows 10 and 2012 R2 serverOS VersionIIS 8.5
Product Version3.0.2 
Summary0001939: Breakpoints unresolved and skipped when web site root is a UNC path in internet information service (8.5)
DescriptionWindows 10 and 2012 R2 server. IIS 8.5. php 7.4.14 . xdebug 3.0.2
IDE Net bean 12, or PhPstorm 2020.2

When the web site root is in a network folder share and mapped as UNC path in Internet Information Service , breakpoint are skipped and in xdebug.log are reported as unresolved

for example
[14720] [Step Debug] <- breakpoint_set -i 17 -t line -f file:///share/bla/bla/bla/www/tmp_2.php -n 12
[14720] [Step Debug] -> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="17" id="147200003" resolved="unresolved"></response>

But the scrips stop at the first line, and cliccking "Resume Program (F9)" it stops at the xdebug_brak(); line. "Step Over (F8)", "Step Into (F7)",... work .

If the same network project folder is mapped in a local folder using a windows symbolic lync (for example Physical path in iis c:\wwwlocalsite\symboliclinkroot) , xdebug works fine, and stops at every breakpoints.

This problem arises from xdebug 2.8 and above. With php 7.3.20 and xdebug 2.7.2 , using the same php network project folder, and setting the UNC Physical path in IIS, brakpoints are correctly resolved (and hit)
Steps To ReproduceWrite any simple script on a network folder and map it in IIS as UNC path. Open in a IDE as NetBean or PhpStorm (probably every other), set some breakpoints and try to hit them.
Tagsiis, path, windows
Operating SystemWindows 10 and 2012 R2 Server
PHP Version7.4.10-7.4.19

Relationships

duplicate of 0001964 feedbackderick WSL UNC paths don't have needed prefix 

Activities

bergafabio

2021-01-25 13:21

reporter   ~0005658

php.ini xdebug section configuration

zend_extension = "C:\PHP\PHP_7-4-14\ext\php_xdebug-3.0.2-7.4-vc15-nts-x86_64.dll"
xdebug.mode=debug
xdebug.client_host=localhost
xdebug.client_port=9003
xdebug.start_with_request=yes
xdebug.log="C:\temp\xdebuglog.log"
xdebug.idekey = PHPSTORM
xdebug.discover_client_host = true

bergafabio

2021-01-29 12:17

reporter   ~0005661

IIS 10.0 in case of Windows 10.
IIS 8.5 in Woindows 2012 R2

derick

2021-05-21 13:20

administrator   ~0005884

I'm closing this as duplicate of 0001964, as that has more information.

Issue History

Date Modified Username Field Change
2021-01-25 11:21 bergafabio New Issue
2021-01-25 11:21 bergafabio Tag Attached: iis
2021-01-25 11:21 bergafabio Tag Attached: path
2021-01-25 11:21 bergafabio Tag Attached: windows
2021-01-25 13:21 bergafabio Note Added: 0005658
2021-01-29 12:17 bergafabio Note Added: 0005661
2021-05-21 13:20 derick Assigned To => derick
2021-05-21 13:20 derick Status new => closed
2021-05-21 13:20 derick Resolution open => duplicate
2021-05-21 13:20 derick Note Added: 0005884
2021-05-21 13:20 derick Relationship added duplicate of 0001964