View Issue Details

IDProjectCategoryView StatusLast Update
0002230XdebugUncategorizedpublic2024-01-16 11:09
ReporterSzpadel Assigned Toderick  
PrioritynormalSeveritymajorReproducibilityrandom
Status closedResolutionfixed 
Product Version3.3.1 
Fixed in Version3.3dev 
Summary0002230: Crash when xdebug and blackfire extensions are active
Description

This issue appears when both xdebug and blackfire extensions are active.
when blackfire is disabled this crash can no longer be reproduced
crash does not happen consistently but some pages can trigger them more often than other

$ php-xdebug -v
PHP 8.1.26 (cli) (built: Nov 21 2023 21:53:48) (NTS gcc x86_64)
Copyright (c) The PHP Group
Zend Engine v4.1.26, Copyright (c) Zend Technologies
with Zend OPcache v8.1.26, Copyright (c), by Zend Technologies
with Xdebug v3.3.1, Copyright (c) 2002-2023, by Derick Rethans
with blackfire v1.92.3~linux-x64-non_zts81, https://blackfire.io, by Blackfire

(gdb) bt full
#0 0x00007f1f430a154c in pthread_kill_implementation () from /lib64/libc.so.6
No symbol table info available.
#1 0x00007f1f43054d06 in raise () from /lib64/libc.so.6
No symbol table info available.
0000002 0x00007f1f430287f3 in abort () from /lib64/libc.so.6
No symbol table info available.
0000003 0x00007f1f43029130 in
libc_message.cold () from /lib64/libc.so.6
No symbol table info available.
0000004 0x00007f1f430ab617 in malloc_printerr () from /lib64/libc.so.6
No symbol table info available.
0000005 0x00007f1f430ad30c in _int_free () from /lib64/libc.so.6
No symbol table info available.
0000006 0x00007f1f430aeedb in _int_realloc () from /lib64/libc.so.6
No symbol table info available.
0000007 0x00007f1f430afcb9 in realloc () from /lib64/libc.so.6
No symbol table info available.
0000008 0x00007f1f4322fdcc in realloc_if_needed (size_to_fit=18, xs=0x55ce53b1d270) at /usr/src/debug/php-pecl-xdebug3-3.3.1-1.el9.remi.8.1.x86_64/src/src/lib/str.c:32
No locals.
0000009 xdebug_str_internal_addl (f=0, le=18, str=0x7f1f43256490 "<tr><td class=\"i\">", xs=0x55ce53b1d270) at /usr/src/debug/php-pecl-xdebug3-3.3.1-1.el9.remi.8.1.x86_64/src/src/lib/str.c:42
No locals.
0000010 xdebug_str_addl (xs=0x55ce53b1d270, str=0x7f1f43256490 "<tr><td class=\"i\">", le=18, f=0) at /usr/src/debug/php-pecl-xdebug3-3.3.1-1.el9.remi.8.1.x86_64/src/src/lib/str.c:60
No locals.
0000011 0x00007f1f4322b4e8 in xdebug_diagnostic_log (message=0x55ce53f8a350 "Select failed: Bad file descriptor", error_code=0x7f1f432564ff "CTRL-SELECT", log_level=3, channel=0) at /usr/src/debug/php-pecl-xdebug3-3.3.1-1.el9.remi.8.1.x86_64/src/src/lib/log.c:106
No locals.
0000012 xdebug_log_ex (channel=0, log_level=3, error_code=0x7f1f432564ff "CTRL-SELECT", fmt=<optimized out>) at /usr/src/debug/php-pecl-xdebug3-3.3.1-1.el9.remi.8.1.x86_64/src/src/lib/log.c:170
message = {l = 34, a = 1025, d = 0x55ce53f8a350 "Select failed: Bad file descriptor"}
argv = {{gp_offset = 32, fp_offset = 48, overflow_arg_area = 0x7ffccd752e20, reg_save_area = 0x7ffccd752d30}}
logged_to_xdebug_log = <optimized out>
0000013 0x00007f1f4322bb9a in xdebug_control_socket_handle () at /usr/src/debug/php-pecl-xdebug3-3.3.1-1.el9.remi.8.1.x86_64/src/src/base/ctrl_socket.c:256
buffer = '\377' <repeats 48 times>, "\210&\314B\037\177\000\000p&\314B\037\177\000\000\210&\314B\037\177\000\000\227\207Q\316U\000\000\003\000\000\000\000\000\000\000\310$\314B\037\177\000\000P%\314B\037\177\000\000\372\207Q\316U\000\000P%\314B\037\177\000\000\070%\314B\037\177\000\000P%\314B\037\177\000\000\227\207Q\316U\000\000\bF\314B\037\177\000\000\360E\314B\037\177\000\000\bF\314B\037\177\000\000\227\207Q\316U\000\000\032\210w\315\374\177\000\000@\000'C\037\177\000\000Pg\200Q\316U\000\000"...
bytes_read = <optimized out>
rc = <optimized out>
timeout = {tv_sec = 0, tv_usec = 0}
master_set = {fds_bits = {128, 0 <repeats 15 times>}}
working_set = {
fds_bits = {128, 0 <repeats 15 times>}}
0000014 0x000055ce517dde3a in zend_llist_apply_with_argument ()
No symbol table info available.
0000015 0x000055ce5162b965 in ZEND_EXT_STMT_SPEC_HANDLER ()
No symbol table info available.
0000016 0x000055ce51633572 in execute_ex.cold ()
No symbol table info available.
0000017 0x00007f1f3ca5f0c0 in ?? () from /usr/lib64/php/modules/blackfire.so
No symbol table info available.
0000018 0x000055ce5185af39 in zend_execute ()
No symbol table info available.
0000019 0x00007f1f3ca7f0ab in bf_load_embedded_code () from /usr/lib64/php/modules/blackfire.so
No symbol table info available.
0000020 0x00007f1f3ca654d8 in zm_activate_blackfire () from /usr/lib64/php/modules/blackfire.so
No symbol table info available.
0000021 0x000055ce517f10b0 in zend_activate_modules ()
No symbol table info available.
0000022 0x000055ce517845f3 in php_request_startup ()
No symbol table info available.
0000023 0x000055ce5163e5cb in main ()
No symbol table info available.
(gdb) frame 8
0000008 0x00007f1f4322fdcc in realloc_if_needed (size_to_fit=18, xs=0x55ce53b1d270) at /usr/src/debug/php-pecl-xdebug3-3.3.1-1.el9.remi.8.1.x86_64/src/src/lib/str.c:32
32 xs->d = xdrealloc(xs->d, xs->a + size_to_fit + XDEBUG_STR_PREALLOC);
(gdb) print xs
$2 = (xdebug_str *) 0x55ce53b1d270
(gdb) print xs->d
$3 = 0x20 <error: Cannot access memory at address 0x20>
(gdb) print xs->a
$4 = 94344655784992
(gdb) print size_to_fit
$5 = 18

if you need anything more, please let me know

TagsNo tags attached.
Operating System
PHP Version8.1.10-8.1.19

Relationships

has duplicate 0002237 resolvedderick Blackfire Probe received a SIGSEGV 

Activities

derick

2023-12-21 10:21

administrator   ~0006737

I think I know what's going on here, but a fix is going to take some time.

For now, if you load blackfire before xdebug (so that they are switched around in php-xdebug -v output), the issue should not show.

cheers,
Derick

derick

2024-01-10 18:46

administrator   ~0006763

A few more questions, as I can not reproduce this:

  • Can you provide the script that causes this — if it's complicated, try to make a small one.
  • What is the output of php -v, and also php --ri blackfire and php --ri xdebug?
  • Ideally, the blackfire source code. Without it, it seems unlikely I can reproduce this. I need to know what bf_load_embedded_code does before I can replicate this, likely.

derick

2024-01-10 18:49

administrator   ~0006764

https://github.com/blackfireio/php-sdk/issues/69

Szpadel

2024-01-10 19:44

reporter   ~0006765

Last edited: 2024-01-11 12:25

Unfortunately I'm not able to provide blackfire source code as it's distributed in binary form.
Providing specific reproduction case is not trivial also, because we encounter this inside some pages in magento admin panel, there just too much code running there to distill any reasonable reproduction script.

Here are outputs that you requested:

php-xdebug -v

PHP 8.1.26 (cli) (built: Nov 21 2023 21:53:48) (NTS gcc x86_64)
Copyright (c) The PHP Group
Zend Engine v4.1.26, Copyright (c) Zend Technologies
    with Zend OPcache v8.1.26, Copyright (c), by Zend Technologies
    with Xdebug v3.2.2, Copyright (c) 2002-2023, by Derick Rethans
    with blackfire v1.92.0~linux-x64-non_zts81, https://blackfire.io, by Blackfire

php-xdebug --ri blackfire

blackfire

Blackfire => enabled
Blackfire => 1.92.0~linux-x64-non_zts81
Timing measurement => cgt
Sessions support => enabled
Num of CPU => 2
Profiling heap memory => 0 Kb
Main instance trigger mode => CLI autotriggered
Main instance => disabled

                   Blackfire runtime active environment
                         No environment detected
                        Blackfire runtime headers
                           No headers detected

Directive => Local Value => Master Value
blackfire.agent_socket => unix:///var/run/blackfire/agent.sock => unix:///var/run/blackfire/agent.sock
blackfire.apm_agent_timeout_ms => 300 => 300
blackfire.apm_browser_collector_endpoint => no value => no value
blackfire.apm_browser_key => no value => no value
blackfire.apm_browser_probe_url => no value => no value
blackfire.apm_connect_at_startup => 0 => 0
blackfire.apm_enable_automatic_browser_probe => 1 => 1
blackfire.apm_enabled => 1 => 1
blackfire.apm_lock_duration => 300 => 300
blackfire.debug.sigsegv_handler => 0 => 0
blackfire.env_id => no value => no value
blackfire.env_token => no value => no value
blackfire.experimental.observer_api => 0 => 0
blackfire.features.auto_profiling => 1 => 1
blackfire.features.curl => 1 => 1
blackfire.features.embedded_code => 1 => 1
blackfire.hostname => no value => no value
blackfire.log_file => no value => no value
blackfire.log_level => 1 => 1
blackfire.server_id => no value => no value
blackfire.server_token => no value => no value

Blackfire developed by Blackfire

extension 'xdebug' detected
INI settings 'blackfire.server_id' and 'blackfire.server_token' should not be configured manually unless you are using a cloud provider with a shared agent

php-xdebug --ri xdebug

xdebug

__   __   _      _
\ \ / /  | |    | |
 \ V / __| | ___| |__  _   _  __ _
  > &lt; / _` |/ _ \ '_ \| | | |/ _` |
 / . \ (_| |  __/ |_) | |_| | (_| |
/_/ \_\__,_|\___|_.__/ \__,_|\__, |
                              __/ |
                             |___/

Version => 3.2.2
Support Xdebug on Patreon, GitHub, or as a business: https://xdebug.org/support

             Enabled Features (through 'xdebug.mode' setting)
Feature => Enabled/Disabled
Development Helpers =>  disabled
Coverage =>  disabled
GC Stats =>  disabled
Profiler =>  disabled
Step Debugger =>  enabled
Tracing =>  disabled

                            Optional Features
Compressed File Support => no
Clock Source => clock_gettime
'xdebug://gateway' pseudo-host support => yes
'xdebug://nameserver' pseudo-host support => yes
Systemd Private Temp Directory => not enabled

Debugger => enabled
IDE Key =>

Directive => Local Value => Master Value
xdebug.auto_trace => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.cli_color => 1 => 1
xdebug.client_discovery_header => HTTP_X_FORWARDED_FOR,REMOTE_ADDR => HTTP_X_FORWARDED_FOR,REMOTE_ADDR
xdebug.client_host => 10.57.1.78 => 10.57.1.78
xdebug.client_port => 9000 => 9000
xdebug.cloud_id => no value => no value
xdebug.collect_assignments => Off => Off
xdebug.collect_includes => (setting removed in Xdebug 3) => (setting removed in Xdebug 3)
xdebug.collect_params => (setting removed in Xdebug 3) => (setting removed in Xdebug 3)
xdebug.collect_return => Off => Off
xdebug.collect_vars => (setting removed in Xdebug 3) => (setting removed in Xdebug 3)
xdebug.connect_timeout_ms => 200 => 200
xdebug.coverage_enable => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.default_enable => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.discover_client_host => Off => Off
xdebug.dump.COOKIE => no value => no value
xdebug.dump.ENV => no value => no value
xdebug.dump.FILES => no value => no value
xdebug.dump.GET => no value => no value
xdebug.dump.POST => no value => no value
xdebug.dump.REQUEST => no value => no value
xdebug.dump.SERVER => no value => no value
xdebug.dump.SESSION => no value => no value
xdebug.dump_globals => On => On
xdebug.dump_once => On => On
xdebug.dump_undefined => Off => Off
xdebug.file_link_format => no value => no value
xdebug.filename_format => no value => no value
xdebug.force_display_errors => Off => Off
xdebug.force_error_reporting => 0 => 0
xdebug.gc_stats_enable => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.gc_stats_output_dir => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.gc_stats_output_name => gcstats.%p => gcstats.%p
xdebug.halt_level => 0 => 0
xdebug.idekey => no value => no value
xdebug.log => no value => no value
xdebug.log_level => 7 => 7
xdebug.max_nesting_level => 256 => 256
xdebug.max_stack_frames => -1 => -1
xdebug.mode => debug => debug
xdebug.output_dir => /tmp => /tmp
xdebug.overload_var_dump => (setting removed in Xdebug 3) => (setting removed in Xdebug 3)
xdebug.profiler_append => Off => Off
xdebug.profiler_enable => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.profiler_enable_trigger => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.profiler_enable_trigger_value => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.profiler_output_dir => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.profiler_output_name => cachegrind.out.%p => cachegrind.out.%p
xdebug.remote_autostart => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.remote_connect_back => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.remote_enable => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.remote_host => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.remote_log => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.remote_log_level => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.remote_mode => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.remote_port => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.remote_timeout => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.scream => Off => Off
xdebug.show_error_trace => Off => Off
xdebug.show_exception_trace => Off => Off
xdebug.show_local_vars => Off => Off
xdebug.show_mem_delta => (setting removed in Xdebug 3) => (setting removed in Xdebug 3)
xdebug.start_upon_error => default => default
xdebug.start_with_request => yes => yes
xdebug.trace_enable_trigger => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.trace_enable_trigger_value => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.trace_format => 0 => 0
xdebug.trace_options => 0 => 0
xdebug.trace_output_dir => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.trace_output_name => trace.%c => trace.%c
xdebug.trigger_value => no value => no value
xdebug.use_compression => 0 => 0
xdebug.var_display_max_children => 128 => 128
xdebug.var_display_max_data => 512 => 512
xdebug.var_display_max_depth => 3 => 3

iamluc

2024-01-11 08:43

reporter   ~0006766

Hi,
Szpadel, could you confirm that setting "blackfire.features.embedded_code = 0" in your PHP config (or with the env var "BLACKFIRE_FEATURES_EMBEDDED_CODE=0") fixes the issue?

Derick, about "I need to know what bf_load_embedded_code does": this function, ran at RINIT, executes some PHP code.
For information, 2 years ago, we had another incompatibility between Xdebug and Blackfire in this same function. We fixed it https://github.com/xdebug/xdebug/pull/786

Szpadel

2024-01-11 09:57

reporter   ~0006767

Hi iamluc,
I can confirm that this successfully prevents crashing from happening

derick

2024-01-11 12:24

administrator   ~0006768

Uhm, are you using Xdebug 3.3.1 (as you filled in in the issue), or 3.2.2 (per phpinfo())?

Szpadel

2024-01-11 13:44

reporter   ~0006769

oh, sorry I checked on different system, but the issue is the same with both environments (the configuration is also the same)

derick

2024-01-11 15:28

administrator   ~0006770

It can't be, as xdebug_control_socket_handle was only introduced in Xdebug 3.3 :-)

Szpadel

2024-01-12 09:21

reporter   ~0006772

OK, so to make everything 100% clear :)
here is dump from system with xdebug 3.3.1 :)

#php-xdebug -v
PHP 8.1.27 (cli) (built: Dec 19 2023 20:35:55) (NTS gcc x86_64)
Copyright (c) The PHP Group
Zend Engine v4.1.27, Copyright (c) Zend Technologies
with Zend OPcache v8.1.27, Copyright (c), by Zend Technologies
with Xdebug v3.3.1, Copyright (c) 2002-2023, by Derick Rethans
with blackfire v1.92.6~linux-x64-non_zts81, https://blackfire.io, by Blackfire

php-xdebug --ri blackfire

blackfire

Blackfire => enabled
Blackfire => 1.92.6~linux-x64-non_zts81
Timing measurement => cgt
Sessions support => enabled
Num of CPU => 2
Profiling heap memory => 0 Kb
Main instance trigger mode => CLI autotriggered
Main instance => disabled

               Blackfire runtime active environment
                     No environment detected
                    Blackfire runtime headers
                       No headers detected

Directive => Local Value => Master Value
blackfire.agent_socket => unix:///run/blackfire/agent.sock => unix:///run/blackfire/agent.sock
blackfire.env_id => no value => no value
blackfire.env_token => no value => no value
blackfire.log_level => 1 => 1
blackfire.log_file => no value => no value
blackfire.server_id => no value => no value
blackfire.server_token => no value => no value
blackfire.hostname => no value => no value
blackfire.apm_enabled => 1 => 1
blackfire.apm_enable_automatic_browser_probe => 1 => 1
blackfire.apm_browser_collector_endpoint => no value => no value
blackfire.apm_browser_key => no value => no value
blackfire.apm_browser_probe_url => no value => no value
blackfire.apm_lock_duration => 300 => 300
blackfire.apm_agent_timeout_ms => 300 => 300
blackfire.apm_connect_at_startup => 0 => 0
blackfire.features.embedded_code => 1 => 1
blackfire.features.auto_profiling => 1 => 1
blackfire.features.curl => 1 => 1
blackfire.experimental.observer_api => 0 => 0
blackfire.debug.sigsegv_handler => 0 => 0

Blackfire developed by Blackfire

extension 'xdebug' detected
INI settings 'blackfire.server_id' and 'blackfire.server_token' should not be configured manually unless you are using a cloud provider with a shared agent

php-xdebug --ri xdebug

xdebug


\ \ / / | | | |
\ V / __| | | | _ _

< / ` |/ \ ' | | | |/ ` |
/ . \ (_| | / |) | || | (| |
/
/ __,|_
|./ \,|_, |
/ |
|
/

Version => 3.3.1
Support Xdebug on Patreon, GitHub, or as a business: https://xdebug.org/support

         Enabled Features (through 'xdebug.mode' setting)

Feature => Enabled/Disabled
Development Helpers => disabled
Coverage => disabled
GC Stats => disabled
Profiler => disabled
Step Debugger => enabled
Tracing => disabled

                        Optional Features

Compressed File Support => yes (gzip)
Clock Source => clock_gettime
'xdebug://gateway' pseudo-host support => yes
'xdebug://nameserver' pseudo-host support => yes
Systemd Private Temp Directory => not enabled

Debugger => enabled
IDE Key =>

Directive => Local Value => Master Value
xdebug.mode => debug => debug
xdebug.start_with_request => yes => yes
xdebug.start_upon_error => default => default
xdebug.output_dir => /tmp => /tmp
xdebug.use_compression => 1 => 1
xdebug.trigger_value => no value => no value
xdebug.file_link_format => no value => no value
xdebug.filename_format => no value => no value
xdebug.control_socket => time: 25ms => time: 25ms
xdebug.log => no value => no value
xdebug.log_level => 7 => 7
xdebug.var_display_max_children => 128 => 128
xdebug.var_display_max_data => 512 => 512
xdebug.var_display_max_depth => 3 => 3
xdebug.max_nesting_level => 256 => 256
xdebug.cli_color => 1 => 1
xdebug.force_display_errors => Off => Off
xdebug.force_error_reporting => 0 => 0
xdebug.halt_level => 0 => 0
xdebug.max_stack_frames => -1 => -1
xdebug.show_error_trace => Off => Off
xdebug.show_exception_trace => Off => Off
xdebug.show_local_vars => Off => Off
xdebug.dump.COOKIE => no value => no value
xdebug.dump.ENV => no value => no value
xdebug.dump.FILES => no value => no value
xdebug.dump.GET => no value => no value
xdebug.dump.POST => no value => no value
xdebug.dump.REQUEST => no value => no value
xdebug.dump.SERVER => no value => no value
xdebug.dump.SESSION => no value => no value
xdebug.dump_globals => On => On
xdebug.dump_once => On => On
xdebug.dump_undefined => Off => Off
xdebug.profiler_output_name => cachegrind.out.%p => cachegrind.out.%p
xdebug.profiler_append => Off => Off
xdebug.cloud_id => no value => no value
xdebug.client_host => 10.15.1.110 => 10.15.1.110
xdebug.client_port => 9000 => 9000
xdebug.discover_client_host => Off => Off
xdebug.client_discovery_header => HTTP_X_FORWARDED_FOR,REMOTE_ADDR => HTTP_X_FORWARDED_FOR,REMOTE_ADDR
xdebug.idekey => no value => no value
xdebug.connect_timeout_ms => 200 => 200
xdebug.scream => Off => Off
xdebug.gc_stats_output_name => gcstats.%p => gcstats.%p
xdebug.trace_output_name => trace.%c => trace.%c
xdebug.trace_format => 0 => 0
xdebug.trace_options => 0 => 0
xdebug.collect_assignments => Off => Off
xdebug.collect_params => On => On
xdebug.collect_return => Off => Off
xdebug.auto_trace => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.collect_includes => (setting removed in Xdebug 3) => (setting removed in Xdebug 3)
xdebug.collect_vars => (setting removed in Xdebug 3) => (setting removed in Xdebug 3)
xdebug.coverage_enable => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.default_enable => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.gc_stats_enable => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.gc_stats_output_dir => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.overload_var_dump => (setting removed in Xdebug 3) => (setting removed in Xdebug 3)
xdebug.profiler_enable => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.profiler_enable_trigger => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.profiler_enable_trigger_value => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.profiler_output_dir => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.remote_autostart => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.remote_connect_back => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.remote_enable => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.remote_host => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.remote_log => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.remote_log_level => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.remote_mode => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.remote_port => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.remote_timeout => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.show_mem_delta => (setting removed in Xdebug 3) => (setting removed in Xdebug 3)
xdebug.trace_output_dir => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.trace_enable_trigger => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)
xdebug.trace_enable_trigger_value => (setting renamed in Xdebug 3) => (setting renamed in Xdebug 3)

derick

2024-01-16 10:57

administrator   ~0006781

https://github.com/xdebug/xdebug/pull/948

Issue History

Date Modified Username Field Change
2023-12-20 15:09 Szpadel New Issue
2023-12-21 10:21 derick Assigned To => derick
2023-12-21 10:21 derick Status new => feedback
2023-12-21 10:21 derick Note Added: 0006737
2024-01-10 18:46 derick Note Added: 0006763
2024-01-10 18:49 derick Note Added: 0006764
2024-01-10 19:44 Szpadel Note Added: 0006765
2024-01-10 19:44 Szpadel Status feedback => assigned
2024-01-11 08:43 iamluc Note Added: 0006766
2024-01-11 09:57 Szpadel Note Added: 0006767
2024-01-11 12:24 derick Note Added: 0006768
2024-01-11 12:25 derick Note Edited: 0006765
2024-01-11 13:44 Szpadel Note Added: 0006769
2024-01-11 15:28 derick Note Added: 0006770
2024-01-12 09:21 Szpadel Note Added: 0006772
2024-01-16 10:57 derick Note Added: 0006781
2024-01-16 10:58 derick Relationship added has duplicate 0002237
2024-01-16 11:09 derick Status assigned => closed
2024-01-16 11:09 derick Resolution open => fixed
2024-01-16 11:09 derick Fixed in Version => 3.3dev