View Issue Details

IDProjectCategoryView StatusLast Update
0000269XdebugUsage problems (Wrong Results)public2007-05-21 12:52
ReportergreubelAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityrandom
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000269: PHP Extension will cause a segfault on various scripts
DescriptionThe phpinfo(); will cause a segfault with xdebug php extension enabled.

If I disable the extension apache will continue its work normally.

This crash will occur sometimes in phpMyAdmin, various custom scripts and a simple phpinfo(); script.
Additional InformationBacktrace:

(gdb) backtrace
#0 0x0072344b in strlen () from /lib/libc.so.6
#1 0x0115058c in php_conv_fp () from /etc/httpd/modules/libphp5.so
0000002 0x01150d11 in ap_php_vsnprintf () from /etc/httpd/modules/libphp5.so
0000003 0x00901ce6 in xdebug_sprintf (fmt=0x90f126 "%s.%08x.%s") at /usr/src/xdebug-2.0.0RC3/xdebug_str.c:95
0000004 0x00907cbb in xdebug_open_file_with_random_ext (fname=0x80ac7d70 "/tmp/trace.2373089536", mode=0x90f13c "w", extension=0x909607 "xt",
    new_fname=0xbf9cdc6c) at /usr/src/xdebug-2.0.0RC3/usefulstuff.c:406
0000005 0x00907e70 in xdebug_fopen (fname=0x80ac7d70 "/tmp/trace.2373089536", mode=0x90960c "w", extension=0x909607 "xt", new_fname=0xbf9cdc6c)
    at /usr/src/xdebug-2.0.0RC3/usefulstuff.c:456
0000006 0x008edd5e in xdebug_start_trace (fname=0x0, options=0) at /usr/src/xdebug-2.0.0RC3/xdebug.c:2639
0000007 0x008e86dc in zm_activate_xdebug (type=1, module_number=48) at /usr/src/xdebug-2.0.0RC3/xdebug.c:760
0000008 0x011997e1 in module_registry_request_startup () from /etc/httpd/modules/libphp5.so
0000009 0x011a03bc in zend_hash_apply () from /etc/httpd/modules/libphp5.so
0000010 0x011958ca in zend_activate_modules () from /etc/httpd/modules/libphp5.so
0000011 0x0114d33a in php_request_startup () from /etc/httpd/modules/libphp5.so
0000012 0x0121a499 in php_ap2_register_hook () from /etc/httpd/modules/libphp5.so
0000013 0x0121aa9e in php_ap2_register_hook () from /etc/httpd/modules/libphp5.so
0000014 0x80024a2d in ap_run_handler () from /usr/sbin/httpd
0000015 0x800283e7 in ap_invoke_handler () from /usr/sbin/httpd
0000016 0x800344ee in ap_process_request () from /usr/sbin/httpd
0000017 0x800312df in ap_register_input_filter () from /usr/sbin/httpd
0000018 0x8002ca1d in ap_run_process_connection () from /usr/sbin/httpd
0000019 0x8002cb1c in ap_process_connection () from /usr/sbin/httpd
0000020 0x80038aa2 in ap_graceful_stop_signalled () from /usr/sbin/httpd
0000021 0x80038d14 in ap_graceful_stop_signalled () from /usr/sbin/httpd
0000022 0x80039c29 in ap_mpm_run () from /usr/sbin/httpd
0000023 0x800101fa in main () from /usr/sbin/httpd
(gdb)
TagsNo tags attached.
Operating SystemLinux 2.6 Fedora Core 6 Kernel Version 2.6.20-1.2948.fc6
PHP Version5.2.1

Activities

sniper

2007-05-18 14:55

reporter   ~0000618

Can you first update to the latest release (2.0.0RC4): http://xdebug.org/link.php?url=xdebug200rc4

greubel

2007-05-18 15:29

reporter   ~0000619

After update to last release the error did not occured after many tests. But the crash occured randomly, so I have no guaranty, that it is resolved.

derick

2007-05-21 12:52

administrator   ~0000620

Okay, let's close it for now... and please reopen if you find it crash again.

Issue History

Date Modified Username Field Change
2007-05-18 13:13 greubel New Issue
2007-05-18 14:55 sniper Note Added: 0000618
2007-05-18 14:55 sniper Status new => feedback
2007-05-18 15:29 greubel Note Added: 0000619
2007-05-21 12:52 derick Status feedback => resolved
2007-05-21 12:52 derick Resolution open => unable to reproduce
2007-05-21 12:52 derick Assigned To => derick
2007-05-21 12:52 derick Note Added: 0000620
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)