View Issue Details

IDProjectCategoryView StatusLast Update
0000128XdebugUsage problems (Wrong Results)public2006-01-24 22:40
ReporterGena01Assigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000128: Apache dies with segmentation fault.
DescriptionMy configuration:
+ PHP 4.3.10 on RedHat 9
+ Apache 2.0.40.
+ Xdebug2 [latest cvs version as of May 27]

I have loaded Xdebug2 as Zend Extension:
------
This program makes use of the Zend Scripting Language Engine:
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies with Xdebug v2.0.0beta3-dev, Copyright (c) 2002, 2003, 2004, 2005, by Derick Rethans
-----

Without touching anything else and just by loading some webpages I am getting:

[notice] child pid 4939 exit signal Segmentation fault (11)

lines in my Apache error_log.

I have managed to capture a backtrace:
------------------------------[btstart]---------------------------------------------
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1077337856 (LWP 13295)]
0x404b0f01 in key () from /etc/httpd/modules/libphp4.so
(gdb) bt
#0 0x404b0f01 in key () from /etc/httpd/modules/libphp4.so
#1 0x40e27d7f in xdebug_crc32tab () from /usr/lib/php4/xdebug2.so
0000002 0x40e2003e in xdebug_var_export (struc=0x8879000, str=0xbfff6600,
level=1, debug_zval=141600450)
   at /home/gennady/xdebug/xdebug-cvs/xdebug/xdebug_var.c:191
0000003 0x40e201de in get_zval_value (val=0xbfff7168, debug_zval=0) at
/home/gennady/xdebug/xdebug-cvs/xdebug/xdebug_var.c:243
0000004 0x40e1196f in add_stack_frame (zdata=0xbfff75b0,
op_array=0x859bc34, type=60) at
/home/gennady/xdebug/xdebug-cvs/xdebug/xdebug.c:861
0000005 0x40e11f06 in xdebug_execute (op_array=0x859bc34) at
/home/gennady/xdebug/xdebug-cvs/xdebug/xdebug.c:1108
0000006 0x4051c0b6 in key () from /etc/httpd/modules/libphp4.so
0000007 0x40e11fb8 in xdebug_execute (op_array=0x83285b4) at
/home/gennady/xdebug/xdebug-cvs/xdebug/xdebug.c:1143
0000008 0x4051a97c in key () from /etc/httpd/modules/libphp4.so
0000009 0x40e11fb8 in xdebug_execute (op_array=0x832a46c) at
/home/gennady/xdebug/xdebug-cvs/xdebug/xdebug.c:1143
0000010 0x4051a97c in key () from /etc/httpd/modules/libphp4.so
0000011 0x40e11fb8 in xdebug_execute (op_array=0x8370444) at
/home/gennady/xdebug/xdebug-cvs/xdebug/xdebug.c:1143
0000012 0x4051a97c in key () from /etc/httpd/modules/libphp4.so
0000013 0x40e11fb8 in xdebug_execute (op_array=0x87b02a4) at
/home/gennady/xdebug/xdebug-cvs/xdebug/xdebug.c:1143
0000014 0x4051a97c in key () from /etc/httpd/modules/libphp4.so
0000015 0x40e11fb8 in xdebug_execute (op_array=0x87b6504) at
/home/gennady/xdebug/xdebug-cvs/xdebug/xdebug.c:1143
0000016 0x4051a97c in key () from /etc/httpd/modules/libphp4.so
0000017 0x40e11fb8 in xdebug_execute (op_array=0x837c85c) at
/home/gennady/xdebug/xdebug-cvs/xdebug/xdebug.c:1143
0000018 0x4051c0b6 in key () from /etc/httpd/modules/libphp4.so
0000019 0x40e11fb8 in xdebug_execute (op_array=0x8218a34) at
/home/gennady/xdebug/xdebug-cvs/xdebug/xdebug.c:1143
0000020 0x4050a890 in key () from /etc/httpd/modules/libphp4.so
0000021 0x404dd854 in key () from /etc/httpd/modules/libphp4.so
0000022 0x4051fb85 in key () from /etc/httpd/modules/libphp4.so
0000023 0x08071b4c in ap_pass_brigade ()
0000024 0x080794cb in ap_core_translate ()
0000025 0x08065f85 in ap_run_handler ()
0000026 0x0806659f in ap_invoke_handler ()
0000027 0x08062d26 in ap_process_request ()
0000028 0x0805e3fc in _start ()
0000029 0x0806f585 in ap_run_process_connection ()
0000030 0x080645e1 in ap_graceful_stop_signalled ()
0000031 0x080647fa in ap_graceful_stop_signalled ()
0000032 0x08064856 in ap_graceful_stop_signalled ()
0000033 0x0806507f in ap_mpm_run ()
0000034 0x0806b15f in main ()
#35 0x42015704 in __libc_start_main () from /lib/tls/libc.so.6
------------------------------[btend]---------------------------------------------

This problem is quite consistent with one specific page. That page is quite complex and loads a bunch of include files. I am investigating trying to narrow it down to something small and simple. Will try to post more when I get more information.
TagsNo tags attached.
Operating SystemLinux
PHP Version4.3.10

Activities

derick

2005-06-30 14:48

administrator   ~0000262

Do you have a short reproducing script already?

Gena01

2005-07-01 16:29

reporter   ~0000263

Just tried against the latest CVS code. Now I get random crashes. Still trying to minimize the size of the code which is proving to be rather difficult since the crashes are now not as consistent.

derick

2006-01-17 21:26

administrator   ~0000336

Any update on this?

derick

2006-01-24 22:40

administrator   ~0000362

Can't reproduce this, nor did I receive any short reproducable script. Please reopen when you can provide one.

Issue History

Date Modified Username Field Change
2005-05-31 15:36 Gena01 New Issue
2005-06-30 14:48 derick PHP Version 4.3.10-dev => 4.3.10
2005-06-30 14:48 derick Note Added: 0000262
2005-06-30 14:48 derick Status new => feedback
2005-07-01 16:29 Gena01 Note Added: 0000263
2006-01-17 21:26 derick Note Added: 0000336
2006-01-24 22:40 derick Status feedback => resolved
2006-01-24 22:40 derick Resolution open => unable to reproduce
2006-01-24 22:40 derick Assigned To => derick
2006-01-24 22:40 derick Note Added: 0000362
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)